[Tickets #2265] Add better shared resource support to menus

bugs@bugs.horde.org bugs at bugs.horde.org
Sat Aug 6 20:54:53 PDT 2005


Ticket URL: http://bugs.horde.org/ticket/?id=2265
 Ticket             | 2265
 Updated By         | Chuck Hagenbuch <chuck at horde.org>
 Summary            | Add better shared resource support to menus
 Queue              | Horde Base
 Version            | 3.0.4
 State              | Feedback
 Priority           | 1. Low
 Type               | Enhancement
 Owners             | 

Chuck Hagenbuch <chuck at horde.org> (2005-08-06 20:54) wrote:

> Done and done, though I'm still not that sure that it's perfect.  

Getting better. :)

1. Please rename the functions to getTasklistWidget()/getCalendarWidget().
Personal taste, but a bit clearer about what the function is.

2. For xhtml, you should use disabled="disabled", not disabled="true".

3. Please spell out boolean and integer in phpdoc comments.

4. You need to echo the result of the function in the templates you use it
in; you just call it, which results in nothing being output.

5. Please don't combine patches to different applications in one file unless
you do the diff from the Horde directory. Try using cvs diff -uRn.

6. Don't use double-quoted strings unless necessary for variable
interpolation or newlines, etc.

7. In several places in Nag, the old code would pre-select the default
tasklist (possibly in Kronolith as well). Your function doesn't provide an
option for that; it should be added back in.

Not trying to be picky for no reason, but since you've been improving it, I
thought I'd give you as much feedback as I could. :)

More information about the bugs mailing list