[Tickets #6100] Hordeauth => true and imp causes login failure

bugs at horde.org bugs at horde.org
Thu Jan 10 20:58:22 UTC 2008


Ticket URL: http://bugs.horde.org/ticket/?id=6100
 Ticket             | 6100
 Created By         | papadopa at gmail.com
 Summary            | Hordeauth => true and imp causes login failure
 Queue              | Horde Groupware Webmail Edition
 Version            | 1.0.3
 Type               | Bug
 State              | Unconfirmed
 Priority           | 3. High
 Milestone          | 
 Patch              | 
 Owners             | 

papadopa at gmail.com (2008-01-10 15:58) wrote:


I've recently set up Horde Webmail on a server of mine and I am facing
problems with the login process. After playing around I somehow narrowed
down the  information I have which lead me here, since I believe there is a
bug hiding somewhere here.

I use LDAP authentication and wish to set up IMP so that it takes the
credentials entered by the user at login, so I set hordeauth to true.
However once doing this, loging in leads to a failure of the login.php and
sidebar.php scripts (connection broken from konqueror, and similar failures
with firefox). If I change the url from mysite/horde to mysite/horde/imp or
mysite/horde/nag (or whatever application I have actually), it works fine.
Entering then mysite/horde brings me back to Horde home just fine.

I then tried removing the IMP block on the horde home page (by clicking on
layout, etc.). Loging out and back in (hordeauth always on true), it worked
fine! Everything was running smoothly.

What I understand from all this is that login works (see my attempts to
change url mentionned above), however trying to use the IMP block on horde
home page leads to complete failure.

I have absolutely no clue as to why, and do not really have the slightest
information on where to look. Hopefully some dev has an idea that could
lead to a fix.

Thanks in advance for your help.

More information about the bugs mailing list