[Tickets #56] Re: IMP maintenance should apply to a configurable folder set.

bugs at horde.org bugs at horde.org
Fri Feb 22 17:09:28 UTC 2008


DO NOT REPLY TO THIS MESSAGE. THIS EMAIL ADDRESS IS NOT MONITORED.

Ticket URL: http://bugs.horde.org/ticket/?id=56
-----------------------------------------------------------------------
 Ticket             | 56
 Updated By         | brook at linuxbox.com
 Summary            | IMP maintenance should apply to a configurable folder set.
 Queue              | IMP
 Version            | HEAD
 Type               | Enhancement
 State              | Feedback
 Priority           | 1. Low
 Milestone          | 
 Patch              | 
 Owners             | 
-----------------------------------------------------------------------


brook at linuxbox.com (2008-02-22 12:09) wrote:

> What is the bitwise or in these lines for?

That's a good question.  To be honest, I didn't write that part of the
patch and I'd ask the guy who wrote it, but he doesn't work here anymore. 
Apologies on my side though, because I agree that it should be changed.  I
do see some other instances of this in the handle_folderselect() and
handle_trashselect() functions in that same file, but I think I'd be
inclined to make it more readable/trustworthy.  Something like the
following would be better, IMO.

         // We might need to create the preference...
        $updated = FALSE;
 	if (!isset($prefs->_prefs['purge_folders_list'])) {
             $updated = $updated || $prefs->add('purge_folders_list', 
 serialize($arr));
         } else {
             $updated = $updated || 
 $prefs->setValue('purge_folders_list', serialize($arr))$
         }

What do you think ?



More information about the bugs mailing list