[Tickets #9197] Re: Group Listing returns fatal error

bugs at horde.org bugs at horde.org
Mon Sep 6 15:32:37 UTC 2010


Ticket URL: http://bugs.horde.org/ticket/9197
  Ticket             | 9197
  Updated By         | hutter at ihs.ac.at
  Summary            | Group Listing returns fatal error
  Queue              | Horde Framework Packages
  Version            | Git master
  Type               | Bug
  State              | Unconfirmed
  Priority           | 2. Medium
  Milestone          |
  Patch              | 1
  Owners             |

hutter at ihs.ac.at (2010-09-06 11:32) wrote:

>> Note: The Group Listing is still empty (as in H3) but this seems to
>> be another problem I'm trying to track down in the code.
> The group-listing does work for me (same configuration as in H3).
What kind of LDAP Implementation do you have? Maybe this applies only  
to active directory servers.
> What still doesn't work is to list the groups in an application  
> (here: kronolith). In H3 we hacked the code to get it worked.
> When you get the Groups in the admin-interface listed, could you  
> check, whether the Groups are even listed in Kronoliths'  
> calendar-adminpanel?
I assume you mean Manage Calenders and then click on the prefernces icon.
Well, after the git pull on 24.8. I can not see this anymore in H4.
Nevertheless, in framework/Group/lib/Horde/Group/Ldap.php in function
  exists($group) the call of @ldap_compare doesn't work (at least with our AD).
I worked around by adding a stristr call if ldap_compare returns 'false'.
This works but it turned out that we now have errors in the apache log:
PHP Warning:  implode(): Invalid arguments passed
This was solved by modifying function getGroupParent($dn).
original code snippet:
if (@ldap_explode_dn($dn, 0) === false) {
             throw new Horde_Group_Exception('Invalid group ID passed  
(bad DN syntax)');
added to this:
  else {
$result = @ldap_explode_dn($dn, 0);

I think it would be better to move this discussion to the horde list.  
The bug as first described is about improper variable names. As soon  
there are relevant new commits to git, I will have a look at this  
again. Maybe we will have to create a new ticket if this is really a  
bug in function getGroupParent.

More information about the bugs mailing list