[Tickets #12427] Re: No UID field returned on vCards

noreply at bugs.horde.org noreply at bugs.horde.org
Thu Jul 11 22:34:31 UTC 2013


Ticket URL: http://bugs.horde.org/ticket/12427
  Ticket             | 12427
  Updated By         | alberto at aftnet.net
  Summary            | No UID field returned on vCards
  Queue              | Turba
  Version            | 4.1.0
  Type               | Bug
  State              | Assigned
  Priority           | 2. Medium
  Milestone          |
  Patch              |
  Owners             | Jan Schneider

alberto at aftnet.net (2013-07-11 22:34) wrote:

>> Hello and thanks for your reply. I'm finding Horde extremely useful
>> so far, so I'm glad to be of assistance.
>> Your patch has indeed fixed the missing UID issue, however OSX's
>> address book still cannot sync.
>> I am attaching the relevant logs from OSX's console below.
>> 10/07/2013 21:17:11.990 Contacts[234]: [CardDAVPlugin-ERROR]
>> -_handleAddsOrModifies: exception processing addsOrModifies The value
>> for 'scheme' should be non-nil and non-empty
>> 10/07/2013 21:17:11.992 Contacts[234]: [CardDAVPlugin-ERROR] Error in
>> _handleAddsOrModifies:removes:inFolderWithURL: The value for 'scheme'
>> should be non-nil and non-empty
>> 10/07/2013 21:17:11.993 Contacts[234]: [CardDAVPlugin-ERROR]
>> -_handleAddsOrModifies:https://<myserveraddress>/rpc.php/addressbooks/alberto/contacts%3adjMHDzbdTiZHr86hrpZTLQ2/ Error Domain=CoreDAVErrorDomain Code=1 "The operation couldn?t be completed. (CoreDAVErrorDomain  
>> error
>> 1.)"
>> 10/07/2013 21:17:11.997 Contacts[234]: [CardDAVPlugin-ERROR]
>> Exception caught while running sync with server: Error
>> Domain=CoreDAVErrorDomain Code=1 "The operation couldn?t be
>> completed. (CoreDAVErrorDomain error 1.)"
>> Unfortunately I have no idea what's going on this time, so I'm afraid
>> I won't be of much assistance.
> Hi Alberto,
> Can you tell me what version of OSX you're running? I noticed during  
> some of my testing that Address Book refuses to add any contacts if  
> it gets an error from the server during any of its requests. In  
> particular, I had trouble with a testing Horde deployment that  
> included the Favourites backend with no data (it caused an HTTP 500  
> status code). Once that error was returned, AB simply refused to  
> continue requesting.
> Perhaps your Horde or Apache logs may indicate what has happened?  
> You might also try to request the vCard or DAV properties via a cURL  
> call.
> To get a list of contacts, try a command like:
>> curl -u username:password -X PROPFIND  
>> 'http://server.com/yourcarddavurl/contacts%3aabcdef1234567'
> I've also seen some chatter online suggesting:  
> http://support.apple.com/kb/TS2481 and  
> http://support.apple.com/kb/TS1627 as possible troubleshooting  
> solutions.

Hello again.

I'm using the latest version of OSX Mountain Lion, fully patched.
For more background information, I am hosting horde using NGINX in the  
domain's root (I have read not doing so can cause issues).

I tried using curl -X PROPFIND as you indicated on the address book's  
collection and individual vcf addresses, but every HTTP status code  
returned was 200. Directly accessing individual vcards also worked  
(UIDs were present).

I disabled the Favourites backend and would have tried syncing again  
if OSX didn't start creating Google accounts instead of Carddav ones  
when I entered my server info. I honestly don't know what's up with  

More information about the bugs mailing list