[Tickets #14021] cannot modify/delete external caldav events

noreply at bugs.horde.org noreply at bugs.horde.org
Sat Jun 20 09:37:41 UTC 2015


Ticket-URL: https://bugs.horde.org/ticket/14021
  Ticket           | 14021
  Erstellt Von     | martin1 at k0k.net
  Zusammenfassung  | cannot modify/delete external caldav events
  Warteschlange    | Kronolith
  Version          | 4.2.8
  Typ              | Bug
  Status           | Unconfirmed
  Priorität        | 2. Medium
  Milestone        |
  Patch            |
  Zuständige       |

martin1 at k0k.net (2015-06-20 09:37) hat geschrieben:

I have an external caldav calendar in Kronolith (Davical I  
can view and add events, but I cannot modify or delete events. Access  
from Lightning works fine, using Lightning I can also modify/delete  
events created by Kronolith.

When I try to modify/delete an event with Kronolith I get a "Resource  
not found" error and the following Apache log: - martin [20/Jun/2015:10:51:21 +0200] "GET  
/davical/caldav.php/martin/calendar/ical0 HTTP/1.1" 404 465 "-"  
"Horde_Http 2.1.5"

sometimes I see ical1 instead of ical0.

Creating this very event looked like this: - martin [20/Jun/2015:10:51:11 +0200] "PUT  
calendar/5585297f-1ed8-483c-9d06-5c4e00000000.ics HTTP/1.1" 201 485  
"-" "Horde_H
ttp 2.1.5"

This is not a recent regression, it has been like this for quite some  
time (I have logs back to October 2014, but it might be older).

My guess is that Kronolith somehow doesn't get the event ID right (but  
my understanding of Horde code ends here...).

I have tried deleting/re-adding the external calendar in Kronolith and  
creating a new principal in Davical but the problem remained the same.  
Davical logs show nothing interesting, other than the fact that Horde  
requested "ical0" which does not exist.

I have seen that Apache mod_rewrite can create problems, so I have  
tried disabling mod_rewrite, but it didn't change anything. Anyway, I  
have no rewrite rules enabled.

Thanks in advance for any hint! If I can help with any log- or  
conf-files, please let me know.


More information about the bugs mailing list