[cvs] commit: incubator/Horde_RDO Table.php incubator/Horde_RDO/Table DB.php RDO.php
Chuck Hagenbuch
chuck at horde.org
Mon Oct 2 20:48:18 PDT 2006
chuck 2006-10-02 20:48:18 PDT
Modified files:
Horde_RDO Table.php
Horde_RDO/Table DB.php RDO.php
Log:
- use php 5-style __construct constructors
- factory() is now marked static
- make Horde_Table_Helper an abstract class and mark abstract methods properly
- rename getFieldsNames to listFields (consistent with Horde_RDO_Model)
- add Horde_RDO_Table_Lens that provides a default lens for the RDO created
and updated fields.
- replace the format_list function and parameter with a decorator parameter
- fix spelling of colum
- avoid static variables that can cause problems with multiple helpers
- use $model->listFields() instead of array_keys($model->getFields())
Revision Changes Path
1.8 +54 -32 incubator/Horde_RDO/Table.php
1.4 +25 -57 incubator/Horde_RDO/Table/DB.php
1.6 +15 -39 incubator/Horde_RDO/Table/RDO.php
Chora Links:
http://cvs.horde.org/diff.php/incubator/Horde_RDO/Table.php?r1=1.7&r2=1.8&ty=u
http://cvs.horde.org/diff.php/incubator/Horde_RDO/Table/DB.php?r1=1.3&r2=1.4&ty=u
http://cvs.horde.org/diff.php/incubator/Horde_RDO/Table/RDO.php?r1=1.5&r2=1.6&ty=u
More information about the cvs
mailing list