[horde] A couple of comments (incl. "No Login Button" issue).

Jamyn jshanley at wiretapped.us
Sat Apr 5 22:40:48 PST 2003

Various problems I've run into with the newest CVS versions (everything I'm
running is current CVS as of tonight).

PHP v4.3.1
Apache v2.0.45
Horde (and friends): CVS/current

"No Login Button" problem with Horde/IMP:
After a fresh CVS install from today, I was also getting the "no login button"
Here's a picture, to avoid typing out a lengthy description:


This was a fresh install (I created brand new directories for Horde).
After a little thinking, I discovered the cause (at least for my situation).


// If you want to use IMP with Horde and don't want to let the users
// login twice (once for Horde and once for IMP) you can setup Horde
// to let IMP do the authentication stuff. Set the auth driver to
// 'application', and add IMP as the driver's parameters:
$conf['auth']['driver'] = 'application';
$conf['auth']['params']['app'] = 'imp';

I want to use this feature.  This feature uses IMP to login. IMP uses
horde/imp/config/conf.php.. This file does not exist until you login at least
once and generate it from the config.xml file.  Catch 22.

I re-commented those two lines above.  After commenting it out, the login page
worked fine, the login button appeared as normal, and I was able to generate
my config files from the .xml files.   Then, I was able to uncomment the two
lines mentioned above, and everything worked just great.

You can reproduce the problem by following the steps above; uncomment those
two lines in horde/config/conf.php, and then make sure you don't have a
horde/imp/config/conf.php file (per default).  Then, go to the login page.

horde/config/conf.php: "Custom Session Handler"

Finally - maybe it's just me, and I'm not understanding the details of this -
but the Custom Session Handler section (in the main horde config file) seems
a little unclear. It will error out for me when I try to use "mysql" as the
driver, even though I am using mysql.

I have the following set under "Database Settings" in horde/config/conf.php:

$conf['sql']['phptype'] = 'mysql';

.. and even though the comments for the Custom Session Handler state:

// driver should we use? Valid options are 'none', 'external', 'dbm',
// 'mysql', 'oci8', 'sapdb', and 'sql'. In the case of 'none' the

If I set the line in Custom Session Handler like:

$conf['sessionhandler']['type'] = 'mysql';

... Horde will freak out and gave me an error page that states:

A fatal error has occurred: Required 'hostspec' not specified in
SessionHandler configuration.

If I change it to just use plain "sql" (even though it lists mysql as a valid
option, and I am using mysql):

$conf['sessionhandler']['type'] = 'sql';

... the error goes away, and everything works fine.


line 33: <br />

The trailing space and "/" is a typo, no?

Themes (apparently) not working for menu bar

I have "Mozilla" selected as my theme.  What's weird is the menu bar on the
left still uses the default dark-blue "horde" theme - but if I select
IMP/mail, IMP will use my selected theme (Mozilla).  So, I'll have the
default theme on the left for the menubar, but Mozilla's colors on the right
side for mail.

I am using a preference database in mysql that was created two months ago, so
if there have been significant changes that might affect how or where the
menubar retrieves its theme information, perhaps that's it.  Not sure.

Thanks for letting me ramble!


$ /usr/games/fortune
Anything that can go wrong will go
Segmentation fault (core dumped)

This mail sent through IMP: http://horde.org/imp/

More information about the horde mailing list