[horde] Auth using customsql.php

Mark mark at 2pmtech.co.uk
Thu May 20 07:51:35 PDT 2004

Hi Chuck, Jan, et al.
	I ran into a slight problem using the customsql Auth module
today, and have attached a patch to fix it.

In the authentication section, it was not retrieving the password from
the database to check with the password that the user had entered, but
trying to match the password directly with that in the database.

This would have worked fine for plain passwords, but when encrypting the
password with crypt, the entered password needs to be encrypted with the
same salt as the original for the match to work.

My patch alters the authentication routine to match the workings of the
sql Auth module.

Mark Wilkinson.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: customsql.php.diff
Type: application/octet-stream
Size: 2581 bytes
Desc: not available
Url : http://lists.horde.org/archives/horde/attachments/20040520/11f3a52d/customsql.php-0002.obj

More information about the horde mailing list