[horde] Undefined class name 'horde'

Stephen Crosby stevecrozz at sbcglobal.net
Wed Aug 10 14:35:45 PDT 2005

I have a working horde installation running imp, kronolith, and turba. I 
wanted to install passwd to allow my users to change their passwords stored 
in a mysql database.

I encountered one problem early on, the error was " Undefined class name 
'horde' " and it mentioned a line in the horde configuration. I found an 
entry for Horde::gettempdir() or something like that. That was in the cache 
system section. So I simply changed it to an explicit directory and tried 
again. Now I get the same error in another file. Here's the error:

Fatal error: Undefined class name 'horde' in 
/var/www/horde-3.0.4/lib/Horde/Registry.php on line 128

line 128 in Registry.php references a function named 

Thanks in advance for any help.

I am including the section of code below:

        /* Import and global Horde's configuration values. */

        /* Start a session. */
        if ($session_flags & HORDE_SESSION_NONE) {
            /* Never start a session if the session flags include
               HORDE_SESSION_NONE. */
            $_SESSION = array();
        } else {
(=>Line  128 )   Horde::setupSessionHandler();
            if ($session_flags & HORDE_SESSION_READONLY) {
                /* Close the session immediately so no changes can be
                   made but values are still available. */

More information about the horde mailing list