[horde] ingo + sieve config

Toomas Aas toomas.aas at raad.tartu.ee
Wed Feb 15 12:45:47 PST 2006


I'm trying to get Ingo (FRAMEWORK_3) going on a server running Cyrus IMAPD 
2.2.12. Cyrus IMAPD, timsieved and the web server running Horde apps are all 
running on the same machine. The timsieved is listening on localhost (port 
2000) and seems to be working properly. I created a user called test_user 
for testing Ingo, and this user can successfully authenticate to timsieved 
from command line:

sieveshell -u test_user -a test_user localhost.

However, when I try to create filter rules with Ingo, I get this Horde error 
message upon clicking the 'Save' button:

There was an error activating the script. The driver said: Connection refused.

This is probably because I can't quite figure out what I should put into 
backends.php. I removed all the examples except the Sieve example and tried 
to modify that one. I currently have the following:

$backends['sieve'] = array(
     'driver' => 'timsieved',
     'preferred' => 'mydomain.com',
	// actually, it's my real domain name
     'hordeauth' => true,
     'params' => array(
         // Hostname of the timsieved server
         'hostspec' => '',
         // Login type of the server
         'logintype' => 'PLAIN',
         // Port number of the timsieved server
         'port' => 2000,
         // Name of the sieve script
         'scriptname' => 'ingo',
         // The following settings can be used to specify an administration
         // user to update all users' scripts.
         // 'admin' => 'cyrus',
         // 'password' => '****',
         // 'username' => Auth::getAuth(),
     'script' => 'sieve',
     'scriptparams' => array()

Even after reading the comments in the beginning of backends.php, I'm still 
not sure what the 'preferred' field actually should be. I also tried 
uncommenting the 'admin', 'password' and 'username' fields (replacing **** 
with the actual password of the cyrus user), but this hasn't helped. I can 
see no error messages in PHP or Apache error logs. However, this message 
appears in Cyrus IMAPD log:

imap[2421] login: localhost [] test_user CRAM-MD5 user logged in

So "something" actually is able to connect, but OTOH there is the 
"Connection refused" message...

If anyone is running a configuration similar to mine and has an example of 
working backends.php for Cyrus Sieve, it would be appreciated.

... When you are arguing with a stupid person, make sure he isn't doing the 

More information about the horde mailing list