[horde] Login (su) authentication fails with Apache error "su: must be run from a terminal"

Eric Jon Rostetter eric.rostetter at physics.utexas.edu
Tue Jul 25 08:03:24 PDT 2006

Quoting Rob Eyre <rob.eyre at oxtrust.org.uk>:

> I'm trying to get Horde to authenticate local users on my Gentoo box
> running Horde 3.1.1.  I've tried Login (su) authentication but the
> apache error_log shows "su: must be run from a terminal".  I also tried
> pam authentication but that gave me a php warning saying that the dll
> wasn't found (even though I changed it to something I know is in
> /etc/pam.d and works).

I'd guess this is a pam issue, not a Horde issue.  It is common for pam+su
to fail if there is no terminal associated with the process doing su.
I can reproduce this on most systems by using pam+su, setting a restriction
in /etc/security/access.conf (or similar file), and trying to do an su
with stdin redirected to /dev/null.

> This is a fresh install which I'm trying to get off the ground.  Any
> help much appreciated.

Best bet, use some other authentication method.  Next best bet, debug why
su is failing, and work around it...

Eric Rostetter
The Department of Physics
The University of Texas at Austin

Go Longhorns!

More information about the horde mailing list