[horde] strange cyrillic symbols with UTF-8

Стоян Цалев stockton at netbg.com
Fri Nov 24 07:53:04 PST 2006

Hi guys,

I'm giving Horde Groupware Webmail Edition RC2 a try and so far I'm quite 
pleased with te results. Today I decided to try horde's unicode support ( 
respectively cyrillic input/output) It did'n work out of the box, the 
cyrillic characters were displayed as question marks (????)  I figured that's 
normal behaviour, because of the $conf['sql']['charset'] = 'iso-8859-1'; line 
in the configuration. So I changed it to $conf['sql']['charset'] = 'utf-8'; , 
created horde database/tables with default character set utf8 and it _almost_ 
worked. The trouble is, when an application (tried mnemo and kronolith) 
writes cyrillic symbols,the output is ok, _except_ for exactly 4 symbols. 
These are: "с" "я" "А" "Н", and they're displayed as "�?" (strange square 
symbol and a question mark)
I was wondering if this is a known horde bug, or perhaps I should dig in the 
underlying software? (Or am I missing something absolutely obvious?)

Some info:
SuSE 10.0 x86_64
mysql  Ver 14.7 Distrib 4.1.13, for suse-linux (x86_64) using readline 5.0
PHP Version: 4.4.0, iconv and mbstring enabled
horde database created with default charset utf8,same goes for the tables

If any other info is needed, I'll provide it right away.

10x in advance for your help!


More information about the horde mailing list