[horde] [freebsd-questions] Can't build php5?

Patrick Baldwin Patrick.Baldwin at studsvikscandpower.com
Mon May 21 23:54:37 UTC 2007

First, my apologies to Beech for replying off-list, I'm on a few others
that work a bit differently, and I was a little quick with the send

On to the issue at hand:

Beech Rintoul wrote:

 > On Monday 21 May 2007, Patrick Baldwin said:
 >> Hi, I'm in the process of trying to build a Horde/IMP server.  I
 >> started by freshly installing & updating 6.2-RELEASE-p4 FreeBSD.  I
 >> then installed IMP package with pkg_add -r imp.  All seemed to go
 >> well.  I then started working my way through configuring the
 >> various newly installed things.
 >> From:
 >> http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/network-a
 >> pache.html
 >> I added:
 >> LoadModule php5_module        libexec/apache/libphp5.so
 >> AddModule mod_php5.c
 >>     <IfModule mod_php5.c>
 >>         DirectoryIndex index.php index.html
 >>     </IfModule>
 >>     <IfModule mod_php5.c>
 >>         AddType application/x-httpd-php .php
 >>         AddType application/x-httpd-php-source .phps
 >>     </IfModule>
 >> To my /usr/local/etc/apache/httpd.conf file.
 >> When I tried to restart Apache, I get:
 >>  apachectl start
 >> Syntax error on line 238 of /usr/local/etc/apache/httpd.conf:
 >> Cannot load /usr/local/libexec/apache/libphp5.so into server:
 >> Cannot open "/usr/local/libexec/apache/libphp5.so"
 >> /usr/local/sbin/apachectl start: httpd could not be started
 >> And sure enough, it's not there.  I go to /usr/ports/lang/php5,
 >> Run make config install, telling it to build Apache module, and
 >> I get:
 >> ===>  Vulnerability check disabled, database not found
 >> ===>  Found saved configuration for php5-5.2.2
 >> => suhosin-patch-5.2.2- doesn't seem to exist in
 >> /usr/ports/distfiles/.
 >> => Attempting to fetch from
 >> http://www.hardened-php.net/suhosin/_media/. fetch:
 >> http://www.hardened-php.net/suhosin/_media/suhosin-patch-5.2.2-0.9.
 >> 6.2.patch.gz: Connection refused
 >> => Attempting to fetch from
 >> ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/.
 >> fetch:
 >> ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/suhosin-patch-5.2
 >> .2- File unavailable (e.g., file not found, no
 >> access)
 >> => Couldn't fetch it - please try to retrieve this
 >> => port manually into /usr/ports/distfiles/ and try again.
 >> *** Error code 1
 >> Stop in /usr/ports/lang/php5.
 >> *** Error code 1
 >> Stop in /usr/ports/lang/php5.
 >> My goal here is to get a working FreeBSD 6.2 Horde/IMP server.  I'm
 >> new to all these things, so if I'm going about this the hard or the
 >> stupid way, please don't hesitate to tell me.  It seemed like the
 >> easiest and fastest way to get a working install would be to
 >> install the package, but maybe I'm wrong.
 >> Regards,
 > The problem is there have been upgrades to php and their server is 
currently down. This has been reported by several people and all I can 
suggest is to try again later. FWIW, I just tried to fetch and it's 
still down.
 > Beech

And apparently continues to be so.  I guess I'll try again tomorrow.

In the meantime, this leaves me wondering if I should try and uninstall
imp, and re-install once this server is back.  I am under the impression
that installing via a package should cause any dependencies of the 
package to be built with the options the package needs to run (if I'm 
wrong on this please let me know),  so it seems like I may end up 
chasing dependencies for awhile if I just proceed from where I am right
now, since it obviously couldn't build PHP with the options needed for
Horde/IMP to work.

Also, it;s mentioned above that several people have reported this 
problem.  My Google searches didn't turn anything up; is there someplace
I should be checking for issues like this before posting here?


Patrick Baldwin
Systems Administrator
Studsvik Scandpower, Inc.
1087 Beacon St.
Newton, MA 02459

More information about the horde mailing list