[horde] Problem with SyncML [SOLVED]

lst_hoe02 at kwsoft.de lst_hoe02 at kwsoft.de
Tue Dec 16 12:12:47 UTC 2008

Zitat von Jan Schneider <jan at horde.org>:

> Zitat von lst_hoe02 at kwsoft.de:
>> Zitat von lst_hoe02 at kwsoft.de:
>>> Zitat von lst_hoe02 at kwsoft.de:
>>>> Hello
>>>> We try Horde/SyncML against Outlook/Funambol to sync contacts. If  
>>>> i create a contact in Outlook it works to get it to the server  
>>>> but the following is logged :
>>>> Dec 11 15:36:40 web HORDE[12369]: [horde] Unable to find addition  
>>>> timestamp for server id  
>>>> 20081211153640.14993yall6j4yg00 at webmail.kwsoft.de at 0 [pid 12369  
>>>> on line 391 of "/srv/www/horde/lib/SyncML/Backend/Horde.php"]
>>>> and in fact the value of "syncml_timestamp" in "horde_syncml_map" is "0".
>>>> I guess this is the reason why updates for the same contact fails?
>>>> Tried to find where it is set and have the impression that  
>>>> "getActionTimestamp" should be defined in registry.php but i  
>>>> cannot find it.
>>> Forget to include :
>>> This is Horde 3.3.2 / Turba 2.3.1 and IMP 4.3.1
>>> Anyone out there where SyncML works in these releases??
>> Found out that the Adressbook which should be synced must have  
>> "use_shares=true" or the sync fail. Bug or feature?
> Sounds like a bug.
> Jan.

Should be filed against Horde, Turba or SyncML?
Any additional information i can offer beside the output from /tmp/sync?



More information about the horde mailing list