[horde] horde.pot missing framework strings?

Luis Felipe Marzagao lfbm.andamentos at gmail.com
Fri Aug 27 04:04:00 UTC 2010


I have updated the pt_BR translations and I realize some strings were 
appearing untranslated on the web, altough when I run the command 
translation.php make etc., it says I have no fuzzy or missing translations.

Then I realized my horde.pot file does not have any strings comming from 
files located under framework/, like, for example:

#:  framework/Alarm/Alarm.php:343
msgid "Dismiss"
msgstr "Liberar"

(this is one of the strings that appear untranslated)

The above string is only in my horde/po/compendium.po file, not in the 
horde.pot and thus, not in the pt_BR.po (as well as not in de_DE.po and 
so forth, as long as I run 'translation.php update locale=xx_XX').

I generated a new horde.pot with "translation.php extract", but the 
result was just the same.

Until recently, I've never had trouble with the translations...

So why the strings from framerok/ files are not getting in the 
horde.pot? Are they supposed to be there, or somewhere else?

And even for those po files that have framework/ files strings, if a do 
a translation.php update, then all the framework strings seems to be 
ripped of as well.

Is this right? How do I get horde to show framework/ strings translated 
on the web access?

Thanks a lot,
Luis Felipe

More information about the horde mailing list