[horde] Installing the RC

Simon Brereton simon.brereton at dada.net
Thu Mar 24 21:55:24 UTC 2011

> From: horde-bounces at lists.horde.org [mailto:horde-
> bounces at lists.horde.org] On Behalf Of Jan Schneider
> Zitat von Simon Brereton <simon.brereton at dada.net>:
> > Hi
> >
> > I've tried this several time and failed every single time.
> > This is a (relatively) fresh Squeeze installation.  The steps I've
> taken are:
> > 	pear channel-discover pear.horde.org
> > 	pear install horde/horde_role-beta
> > 	pear run-scripts horde/horde_role
> > enter /usr/share/horde4 at the prompt...
> >
> > To install the beta release of Horde, run the following commands:
> >
> > 	pear install --alldeps horde/horde-beta
> > Install all the other Horde stuff
> > 	pear install horde/imp-beta
> > 	pear install horde/mnemo-beta
> > 	pear install horde/turba-beta
> > 	pear install horde/ingo-beta
> >
> > go to the /usr/share/horde4/config/ directory of your Horde
> > installation and copy conf.php.dist to conf.php:
> >
> > 	cd /usr/share/horde4/config/
> >
> > And at this point I have a problem.  There is nothing in
> > /usr/share/horde4 other than the js folder...
> >
> > Can you tell me what I'm doing wrong?
> Not really. Everything look correct. I'm curious: what *is* in the
> js/ directory?
> You can see where the packages are installed with:
> pear list-files horde/horde

At the moment I can't tell you.  I just tried it again.

root at jonty:~# pear install horde/horde_role-beta
horde/horde_role is already installed and is the same as the released version 1.0.0RC1

root at jonty:~# pear run-scripts horde/horde_role
Including external post-installation script "/usr/share/php/PEAR/Installer/Role/Horde/Role.php" - any errors are in this script
Inclusion succeeded
running post-install script "Horde_Role_postinstall->init()"
init succeeded
Filesystem location for the base Horde application : /usr/share/horde4
Configuration successfully saved to PEAR config.
Install scripts complete

root at jonty:~# pear install horde/horde-beta

fails with..

No valid packages found
install failed

I've checked and none of the packages are installed...

root at jonty:~# pear uninstall horde/ingo-beta
horde/ingo not installed
root at jonty:~# pear uninstall horde/turba-beta
horde/turba not installed
root at jonty:~# pear uninstall horde/mnemo-beta
horde/mnemo not installed
root at jonty:~# pear uninstall horde/imp-beta
horde/imp not installed
root at jonty:~# pear uninstall horde/horde-beta
horde/horde not installed

root at jonty:~# pear list-files horde/horde
`horde/horde' not installed

So, now I'm really stuck.  Is there away to completely reset things?



More information about the horde mailing list