[horde] Errors Preventing Upgrade To Horde 5

Gordon Dickens gordon at dickens.com
Wed Nov 14 11:27:39 UTC 2012

Hi Oscar,

All that is covered in your referenced "UPGRADING" link is how to 
migrate data. In my case, that is not necessary since I have my 
$conf['datatree']['driver'] parameter set to "None". In other words, 
although horde_datatree is installed, I am not using it and there is not 
any reason to migrate data.

I did figure out the solution to my problem.  That is, I simply needed 
to remove horde_datatree with:

pear uninstall horde/horde_datatree

The upgrade then proceeded without any problems.

I recommend that the documentation be amended to cover this issue. That 
is, if horde_datatree is installed from prior Horde 3/4 versions then 
you need to uninstall it prior to upgrading to Horde 5.

Also, the Horde 5 application modules, such as Imp, would not load 
initially and I had to reinstall horde-core with the command:

pear install -f horde/Horde_Core

After which, Imp and the other apps started working correctly.



On 11/13/2012 02:48 PM, Oscar del Rio wrote:
> On 11/13/12 02:12 PM, Gordon Dickens wrote:
>> horde/horde_datatree requires package "horde/Horde_Core" (version >= 
>> 1.0.0, version <= 2.0.0, excluded versions: 2.0.0), downloaded 
>> version is 2.0.2
>> horde/Horde_Core cannot be installed, conflicts with installed packages
>> Does anybody have any recommendations for fixing these errors? I 
>> realize that horde_datatree support has been removed so is that my 
>> problem? If so, how do I resolve it?
> It seems to be documented:
> http://www.horde.org/apps/horde/docs/UPGRADING

More information about the horde mailing list