[horde] strange problem on login

Arjen de Korte arjen+horde at de-korte.org
Tue Jan 8 18:10:11 UTC 2013

Citeren "Jens-U. Mozdzen" <jmozdzen at nde.ag>:

> Hi list,
> we just experienced a strange error situation and I felt like asking  
> if anyone had seen this already:
> I've been successfully using an up-to-date H5 server on client  
> machine A (openSUSE 12.2, Firefox 17.0), user 1.
> Today I had to use another client machine at a different location  
> (similar to client A - openSUSE 12.2, Firefox 17.0, latest patches),  
> again as user 1:
> - I logged in to H5, got the portal view (dynamic), current emails  
> etc were listed
> - I clicked to see my inbox, but got a Horde report about a severe  
> server error "with details in the log" (the log reported that the  
> e-mail server wouldn't support secure connection)
> - logout, login -> get portal as above
> - click "reload page" button of browser: no emails, no dates, etc.  
> and Horde's log fills with "e-mail server doesn't support secure  
> connections" messages
> My first guess were cookie problems, so I deleted all cookies for  
> that server, even those for other applications, and made sure  
> there's no exception entry (block all cookies from host) in the  
> browser config. Then restarted the browser, but symptoms as above.
> Using a test user account (user 2) with the same browser on client  
> B, things worked flawlessly. But a third user reported the same  
> symptoms as I have, but from a different machine C.
> So:
> - It's not caused by the account alone (works on client A, fails on client B)
> - It's not caused by the client alone (using the same client, user 2  
> works but user 1 fails)
> - Accessing the IMAP server works at the start of the session, as I  
> can see new emails and calendar entries in the portal view, until  
> the first reload.
> To cut a long story short: After deleting the Horde cache on the  
> server and restarting the Apache httpd, everything was fine. No  
> problems since then.
> So:
> - It's not caused by the (Horde, IMAP) server configuration alone  
> (cache cleared - now it fully works)
> All affected clients were used to access Horde4 on the same server  
> and probably had old cookies with a matching path stored in the user  
> profile. But we have more than one machine which was used for old  
> Horde accounts as well, that didn't exhibit this behavior.
> Has anyone seen something similar or maybe even has an explanation?  
> Is it the consequence of a wrongly configured Horde server? I'm  
> puzzled, and of course am not always in the situation to clear the  
> cache and restart the server in production...

I had similar problems yesterday too and Horde wasn't able to load any  
preferences for existing users. Like you, clearing the cache and  
restarting Apache fixed it (and the problems have not occurred since).  
Looking through the server logs, it might have to do with  
mysql-community-server that got a security update yesterday, around  
the time when I first noticed that something was wrong.

Best regards, Arjen
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 308 bytes
Desc: PGP digitale ondertekening
URL: <http://lists.horde.org/archives/horde/attachments/20130108/fefbe75e/attachment.bin>

More information about the horde mailing list