[horde] Horde Upgrade javascript issues

Huggy-Bear huggy-bear at luukku.com
Fri Feb 8 15:18:25 UTC 2013


This is most likely some setting I am missing somewhere, which I do not find, but for you this might be obvious.

System: Ubuntu 12 LTS with latest patches

Procedure: I upgraded Horde from version 4.x (including all modules) to latest with command pear upgrade -a -B -c horde and got a few warnings related to depreciation and failed for alpha versions (I installed them manually from channels afterwards). Memcache.so was giving error for "Cannot find config.m4." so I uninstalled horde/Horde_Memcache and pecl unistall memcache, because I have never used it (at least not in the Horde config).

All Horde module updates went ok. I run post-install script as it was instructed. I do not know should directory for the post-install-script be absolute or relative to /var/www, so I just gave "horde" for it. I also tried /var/www/horde, but problem I am facing is the same. Schema and configuration updates went smoothly from the settings-page.

Problem I am having: 
- if I use "Automatic mode" for login, I in the left side pane "Loading" (IMP 6.0) forever. The same applies for Kronolith and other modules trying for dynamic views
- if I use "Basic mode" for login, IMP at least seems to work quite ok, but as an example if I select message from the Inbox listing (checkbox) and select "Delete", nothing happens. But if I open message and then press "Delete", mail will be be deleted.

- syslog has errors like these:

"HORDE: [horde] PHP ERROR: filemtime(): stat failed for /var/www/horde/imp/lib/../../js/growler.js [pid 2070 on line 102 of "/usr/share/php/Horde/Script/File.php"

"HORDE: [imp] PHP ERROR: filemtime(): stat failed for /var/www/horde/imp/lib/../../js/date/en-US.js [pid 2101 on line 102 of "/usr/share/php/Horde/Script/File.php"]

HORDE: [imp] PHP ERROR: filemtime(): stat failed for /var/www/horde/imp/lib/../../js/accesskeys.js [pid 2101 on line 102 of "/usr/share/php/Horde/Script/File.php"]

HORDE: [imp] PHP ERROR: filemtime(): stat failed for /var/www/horde/imp/lib/../../js/prototype.js [pid 2101 on line 102 of "/usr/share/php/Horde/Script/File.php"]

HORDE: [kronolith] PHP ERROR: file_get_contents(/var/www/horde/imp/lib/../../js/keynavlist.js): failed to open stream: File or directory does not exist [pid 2012 on line 264 of "/usr/share/php/Horde/PageOutput.php"]

... depending what I try, error related to javascripts occur.

I have checked that referred files are there.

What should I do next to find root cause for this problem?

- Jari

Luukku Plus -paketilla pääset eroon tila- ja turvallisuusongelmista.
Hanki Luukku Plus ja helpotat elämääsi. http://www.mtv3.fi/luukku

More information about the horde mailing list