[horde] ActiveSync for INBOX stops syncing after ERR "Collection does not exist"

Volker Then horde40 at volkerthen.com
Thu Mar 14 15:26:49 UTC 2013

Hi all,

ActiveSync was working for quite some time on my iPhone4 (6.1.2) with  
"Push" activated in the iPhone settings.

But now the Syncing of my inbox fails after a few dozen of messages.  
In the log file I can see this:

2013-03-14T16:06:58+01:00 DEBUG: [26682] Initializing state for  
collection: INBOX, synckey: {5141e457-bd6c-4454-8b16-6b44c0a8bb01}28
2013-03-14T16:06:58+01:00 DEBUG: [26682] Loading state for synckey  
2013-03-14T16:06:58+01:00 ERR: [26682] Could not find state for  
synckey {5141e457-bd6c-4454-8b16-6b44c0a8bb01}28.
2013-03-14T16:06:58+01:00 ERR: [26682] State gone, PING terminating  
and forcing a SYNC:
2013-03-14T16:06:58+01:00 DEBUG: [26682] Changes available!

and a few seconds later this:

2013-03-14T16:07:10+01:00 DEBUG: [28973] Found 1 message changes in INBOX.
2013-03-14T16:07:10+01:00 DEBUG: [28973] Checking for PIM initiated changes.
2013-03-14T16:07:10+01:00 ERR: Collection does not exist.

and after this, no more email messages get synced.

In the first place I suspected the jailbroken device doing something  
to the syncing operations. Then I reset the phone to factory defaults  
and tried again, same result.

Contacts, calendar and tasks are still working with "Push" activated.

I'm using Debian 7.0 (wheezy) and most recent Horde version.

And idea?



More information about the horde mailing list