[horde] Possibly missing dependency on Horde_HashTable [SOLVED]

Stephan Kleber stephan at admin.nabira.de
Thu Jun 6 11:15:35 UTC 2013

Hi all,

I just upgraded via pear and ran into to problem of a non functioning
horde (blank page). php-error.log says:

[06-Jun-2013 13:03:48] PHP Fatal error:  Class
'Horde_HashTable_Memcache' not found in
/usr/share/php/Horde/Core/Factory/HashTable.php on line 35

Relevant snippets of the installation process are:

Did not download optional dependencies: horde/Horde_HashTable,
horde/Horde_Mongo, use --alldeps to download automatically
horde/Horde_SessionHandler can optionally use package
"horde/Horde_HashTable" (version >= 1.0.0, version <= 2.0.0alpha1,
excluded versions: 2.0.0alpha1)
horde/Horde_Cache can optionally use package "horde/Horde_HashTable"
(version >= 1.0.0, version <= 2.0.0alpha1, excluded versions: 2.0.0alpha1)
upgrade ok: channel://pear.horde.org/Horde_SessionHandler-2.2.0
upgrade ok: channel://pear.horde.org/Horde_Mime-2.2.1
upgrade ok: channel://pear.horde.org/Horde_Cache-2.2.0
upgrade ok: channel://pear.php.net/Date_Holidays_EnglandWales-0.1.5
upgrade ok: channel://pear.horde.org/Horde_Core-2.5.0
upgrade ok: channel://pear.horde.org/Horde_Imap_Client-2.11.4
upgrade ok: channel://pear.horde.org/Horde_ActiveSync-2.4.0
upgrade ok: channel://pear.horde.org/Horde_Dav-1.0.0
upgrade ok: channel://pear.horde.org/Horde_Rpc-2.1.0
upgrade ok: channel://pear.horde.org/horde-5.1.0
upgrade ok: channel://pear.horde.org/imp-6.1.0
upgrade ok: channel://pear.horde.org/ingo-3.1.0
upgrade ok: channel://pear.horde.org/nag-4.1.0
upgrade ok: channel://pear.horde.org/kronolith-4.1.0
upgrade ok: channel://pear.horde.org/mnemo-4.1.0
upgrade ok: channel://pear.horde.org/turba-4.1.0

The issues was SOLVED by:
www:~# pear install horde/Horde_HashTable
install ok: channel://pear.horde.org/Horde_HashTable-1.0.0

Obviously one of the packages depends optionally on Horde_HashTable
where it should be a mandatory dependency.


More information about the horde mailing list