[horde] EMERG: HORDE-BETA Missing required state object [pid 15927 on line 122 of "/usr/share/git-horde5/framework/ActiveSync/lib/Horde/ActiveSync/Driver/Base.php"]

Tomi Orava Tomi.Orava at ncircle.nullnet.fi
Fri Jan 17 19:01:17 UTC 2014

On 01/15/2014 06:57 AM, Michael M Slusarz wrote:
> Quoting Tomi Orava <Tomi.Orava at ncircle.nullnet.fi>:
>>> If/when you find a commit that works for you, you can use git bisect to find the commit that breaks it.
>> I just tried to upgrade to latest GIT revision and got exactly the same error
>> message and white screen on admin config page. After git bisect, the end result was the
>> following commit:
>> The used HEAD was:             8b509f0e85803987c637f6feaf84c32800f488b7
>> and the known working version: 19efe8dac153be390c624d7e8de8ce4b3fde047c
>> 54a1644952151bea3dc942e0b334e07810e9e188 is the first bad commit
>> commit 54a1644952151bea3dc942e0b334e07810e9e188
>> Author: Michael M Slusarz <slusarz at horde.org>
>> Date:   Mon Nov 4 00:40:29 2013 -0700
>>     Convert Horde_Session to Horde_Pack
>>     Add to 6.2 branch so we (I) can test in a production-like environment.
>> :040000 040000 fdd053032dac0362b9f0620d06b315d58274d6e5 031e3c54a01429f7603dc758550b6c12cc4683eb M      framework
>> Once I get the empty screen by browsing to admin config page or to kronolith
>> page, the session will not recover ---> all the screens are empty after that.
>> Perhaps this gives someone ideas what might be the real problem.
> Not really, since everything relating to that patch works for me (and evidently the other Horde developers).  You will now have to track down where in the code this is failing for you.

As a follow up, this problem was eventually fixed by dropping the whole mysql database and re-creating from
scratch with the latest GIT master version.

However, the initial table creation didn't work at all until I reverted the commit below:

commit 133a0d5acadd3e6950260698730084f283956d75
Author: Jan Schneider <jan at horde.org>
Date:   Wed Dec 18 12:16:08 2013 +0100

    Set precision and scale on non-decimal columns too, if explicitly requested.

diff --git a/framework/Db/lib/Horde/Db/Adapter/Base/Schema.php b/framework/Db/lib/Horde/Db/Adapter/Base/Schema.
index 3e893ab..be16158 100644
--- a/framework/Db/lib/Horde/Db/Adapter/Base/Schema.php
+++ b/framework/Db/lib/Horde/Db/Adapter/Base/Schema.php
@@ -896,7 +896,9 @@ abstract class Horde_Db_Adapter_Base_Schema
         $sql = is_array($native) ? $native['name'] : $native;
-        if ($type == 'decimal') {
+        if ($type == 'decimal' ||
+            isset($native['precision']) || isset($native['scale']) ||
+            isset($precision) || isset($scale)) {
             $nativePrec  = isset($native['precision']) ? $native['precision'] : null;
             $nativeScale = isset($native['scale'])     ? $native['scale']     : null;

The problem was that with this patch the mysql "AUTO_INCREMENT KEY" had the value "(i, i)"
appended together, which mysql didn't like at all. I quess that not many have tried with the
GIT versions since december 18. to re-create everything using mysql.

Also, it looks like the latest GIT master has some problems in showing all imap mailboxes
whenever the option "use imap subscribtions" has been turned off. The old
version "19efe8dac153be390c624d7e8de8ce4b3fde047c" that I used, was able to show all maiboxes
just fine, but with the latest version, I'm unable to for example set the "trash mailbox"
as the only available mailboxes are "inbox" and "virtual trash".
If I choose to enable the imap subscriptions, I would have to subcribe invidually every single
sub-mailbox under my "RSS." folder as the web-interface doesn't allow be to subsribe RSS at all
---> ie. the menu option is not there. The child mailboxes have this subsribe menu option in dynamic

---> If the imap subscription is _not_ activated, also my S3 4.3 Android/Activesync phone is able
to list just the same "inbox" in the "Show all folders" and nothing else.

I tried bisecting these commits but the commits around november time frame make the whole
activesync system fail in here ---> I was unable to get any valid results.

Tomi Orava

More information about the horde mailing list