[horde] activesync was working but broke?

Jason Haar Jason_Haar at trimble.com
Sun Sep 28 22:08:27 UTC 2014

Hi there

I was happily running Horde-webmail 5.2.1 with just a single user - me 
- synchronizing to my Android Phone, Tablet and Outlook 2013

On Sunday they all stopped working. No real error, just stopped
synchronizing email. The normal web interface to horde still worked, but
the ActiveSync component broke. I upgraded to 5.2.2 but it didn't help.
I deleted the profile on the phone and created a new one - didn't help.
I used Horde to remove the device from the server and created a new
client profile  - didn't help

I'm a bit stuck, clearly something has become borked, but I don't know
what. I haven't tried trashing the mysql database yet, but that will
lose contacts/calendaring and I don't want that. I have turned up
logging to DEBUG and nothing really shows up in there, except once in a
while I see

2014-09-28T14:10:27+13:00 ERR: [32702] Unknown backend error skipping
message: IMAP error reported by server.
2014-09-28T14:10:27+13:00 ERR: [32702] Unable to fetch message: IMAP
error reported by server.
2014-09-28T14:10:27+13:00 ERR: IMAP error reported by server.

...but I can't get horde to run except in TLS mode, so I can't even
sniff the traffic to see what the IMAP error is. But that error doesn't
show up every time I get the client to do a 'sync', so I'm not sure if
it's the root cause. The IMAP server is dovecot-2.0.9 (CentOS-6)

Any ideas what I can do to diagnose the root cause?



Jason Haar
Corporate Information Security Manager, Trimble Navigation Ltd.
Phone: +1 408 481 8171
PGP Fingerprint: 7A2E 0407 C9A6 CAF6 2B9F 8422 C063 5EBB FE1D 66D1

More information about the horde mailing list