[horde] upgrading / scripts folder?

Joe @ 3ZZZ joe at 3zzz.net
Sun Oct 12 22:29:22 UTC 2014

Quoting Michael J Rubinsky <mrubinsk at horde.org>:

> Quoting Joe @ 3ZZZ <joe at 3zzz.net>:
>> Quoting Michael J Rubinsky <mrubinsk at horde.org>:
>>> Please keep discussion on the mailing list.
>>> Quoting Joe @ 3ZZZ <joe at 3zzz.net>:
>>>> Quoting Michael J Rubinsky <mrubinsk at horde.org>:
>>>>> Quoting Joe at 3zzz.net:
>>>>>> On 10/6/2014 7:33 AM, Michael J Rubinsky wrote:
>>>>>>> Quoting Joe @ 3ZZZ <joe at 3zzz.net>:
>>>>>>>> Hello -
>>>>>>>> I've been trying to upgrade from Horde 3 to 5, but seem to be  
>>>>>>>> stuck. My new installation of Horde doesn't have a scripts  
>>>>>>>> directory - is that where I'd find any SQL upgrade scripts?  
>>>>>>>> Haven't been able to find that anywhere.  Do I need to look  
>>>>>>>> on Git?
>>>>>>> Starting with Horde 4, we moved to a "migrations" system that  
>>>>>>> is responsible for maintaining the db schema between versions.  
>>>>>>> The migration system assumes that any existing database schema  
>>>>>>> that hasn't been migrated is in the same state it would have  
>>>>>>> been as of the last stable version of Horde 3. It sounds to me  
>>>>>>> like at least some of your applications were not fully up to  
>>>>>>> date with H3 when you decided to move to H5.
>>>>>>>> Below is a summary of the issues I'm seeing on the new  
>>>>>>>> system.  Thank you in advance for any advice or suggestions,
>>>>>>>> Joe
>>>>>>>> installed horde with pear and it did not seem to come with a  
>>>>>>>> scripts directory?
>>>>>>>> "At least one database schema is outdated"
>>>>>>>> mnemo is coming from H3 (2.2.3)
>>>>>>>> when i try to update the schema for mnemo, this is the error:
>>>>>>>> QUERY FAILED: Unknown column 'share_parents' in  
>>>>>>>> 'mnemo_shares' ALTER TABLE `mnemo_shares` CHANGE  
>>>>>>>> `share_parents` `share_parents` varchar(4000)
>>>>>>> See above.
>>>>>> Hello -
>>>>>> I brought up a copy of the old Horde 3 server and upgraded all  
>>>>>> items to the latest H3 versions.  They were all minor updates  
>>>>>> and didn't require any database updates.  The setup page shows  
>>>>>> they're all ready yet mnemo_shares table still doesn't have a  
>>>>>> share_parents column, so I don't think upgrading mnemo from  
>>>>>> 2.2.3 to 2.2.5 was enough to make this work.
>>>>>> I looked in scripts/upgrade and there's nothing new for my  
>>>>>> versions.  I looked at sharesng.sql, but I can see it won't add  
>>>>>> that column...
>>>>>> upgrades]# grep share_parents * --> no output...
>>>>>> Is upgrading to H5 on this copy going to work?  What provides  
>>>>>> this column?
>>>>> It's added in the "5" migration for Mnemo. See  
>>>>> mnemo/migration/5_mnemo_upgrade_sqlnghierarchal.php
>>>> Thank you!  I see the script - is there any documentation about  
>>>> the migration folders?  I haven't been able to find anything yet.  
>>>>  This is what I have, Is it best to run everything in there, or  
>>>> is it something that should have happened through the web  
>>>> Administration?
>>> These are the files that are executed when you upgrade the schema  
>>> via the web administration. Alternatively, you can run them  
>>> manually using the horde-db-migration script.
>> i wonder why the column didn't get added when i updated through the  
>> web config initially?  I finally just added the share_parents  
>> column to mnemo_shares manually and it seemed to work.  Same for  
>> Kronolith.
>>> ALTER TABLE kronolith_shares add column share_parents int(11);
>> (the datatype's wrong but who cares since horde-db-migrate is  
>> looking to fix this column anyway... and it did, now varchar(4000))  
>>  After running horde-db-migrate from cmd line, config page now says  
>> "SQL DB schema is ready."  for all apps.
>> But my memos don't show up.  I can see in the database that  
>> mnemo_memos.memo_owner of my old notes is my email address in plain  
>> text, whereas for the new notes it's an encrypted string.  Updated  
>> all of my notes by doing an SQL
>> UPDATE mnemo_memos SET memo_owner = 'Encrypted string' WHERE  
>> memo_owner = 'my email', and there they are!
>> Now how can I run the same update for my users; how can I encrypt  
>> their email to get the new owner id?
> That's not an encrypted string, it's a share-id. Sounds like maybe  
> you switched share drivers during the upgrade from H3 to H5?

ah. yeah.  before we had datatree now we have Next Gen SQL.  I see in  
the H3 turba/scripts/upgrades folder there's a conversion script I  
should have run before the upgrade,  convert_datatree_shares_to_sql.php
Wonder if that would work on the H5 install, or if I need to go back  
and convert a copy of the H3 install to next gen SQL then bring that  
db over?

Another issue I'm seeing is that only the administrator can see the  
turba "Address Book" link I believe because of permissions, the horde  
permissions don't save and I can't add any new ones.  I wonder if this  
is related or something else I changed without realizing the impact.

thank you very much for your help!

More information about the horde mailing list