[horde] Horde Passwd module is not properly configured [SOLVED]

Jan Schneider jan at horde.org
Sat Dec 3 20:11:47 UTC 2016

Am 2. Dezember 2016 17:39:40 MEZ, schrieb Admin Beckspaced <admin at beckspaced.com>:
>On 30.11.2016 18:28, Admin Beckspaced wrote:
>> On 30.11.2016 16:44, Michael J Rubinsky wrote:
>>> Some ideas: Make sure that the hostspec you are using if you are 
>>> explicitly specifying it in passwd's backends.local.php file matches
>>> the host that the dbuser was granted access to. I.e., 'localhost', 
>>> '' may not be viewed as the same host from the rdms' point 
>>> of view.
>>> Also, if you are using a SQL based auth, you might try using the 
>>> hordeauth backend in passwd.
>> Thanks for your reply and ideas Michael,
>> I already had something like that in mind. As I had specified in the 
>> backends.local.php
>>     'params' => array(
>>         'phptype' => 'mysql',
>>         'hostspec' => 'localhost',
>> and if I look at the error:
>> Nov 30 09:45:04 cx20 HORDE[28207]: [passwd] Could not instantiate
>> PDOException: SQLSTATE[HY000] [1045] Access denied for user 
>> 'dbuser'@'' (using password: YES) [pid 28207 on line 129 of 
>> "/srv/ssl/webmail/httpdocs/passwd/lib/Factory/Driver.php"]
>> it there says '' instead of 'localhost'
>> the database user has granted access to 'localhost' and not
>> will have a look again tomorrow and report back ;)
>> thanks for your time & input
>> greetings
>> Becki
>Hello there again,
>just to finish and close this thread as SOLVED.
>I had a look in the MySQL user permissions today. I got my database
>setup permissions for host 'localhost' only!
>adding the database user with permission for host '' and then 
>reload the MySQL privileges and finally I was able to change the 
>password with Horde / Passwd ;)
>Only strange thing, no matter if I define 'hostspec' => 'localhost' or 
>'hostspec' => '127.0.01' it always gets reported as ''
>Dec 02 17:26:17 cx20 HORDE[17065]: [passwd] Could not instantiate PDO. 
>PDOException: SQLSTATE[HY000] [1045] Access denied for user 
>'dbuser'@'' (using password: YES) [pid 17065 on line 129 of 
>Is this perhaps a bug in Horde? As it doesn't pick up the host as
>And since I found out that 'localhost' and '' are not the same
>in MySQL / MariaDB, this could perhaps be of interest?
>Anyway, thanks a lot for all your help & suggestions
>Horde mailing list
>Frequently Asked Questions: http://horde.org/faq/
>To unsubscribe, mail: horde-unsubscribe at lists.horde.org

This is because you use tcp connections. If you use unix connections "localhost" will be used. 

More information about the horde mailing list