[horde] problem with new install on new Centos 7.5 system

Edward Burr egburr at burr.cc
Sun Nov 25 05:09:17 UTC 2018

I realize it's holiday time here in the US, but that has given me lots  
of time to play with this. I'm not trying to push for faster answers,  
just reporting what I've tried.

I've gone so far as wiping the box and completely re-installing CentOS  
7.5 from scratch and bringing it up to latest updates, and then  
attempting this Horde Groupware installation again following the  
suggestions given in this email thread. I am again stuck at the same  
point as described below.

Is there any way to get around Horde_Core's requirement for a level of  
Horde_Backup that doesn't exist, while still handling all the rest of  
Horde_Core's requirements during installation?

And any thoughts on the pecl/sasl and pecl/idn issues?


Quoting Edward Burr <egburr at burr.cc>:

> Quoting Jan Schneider <jan at horde.org>:
>> Zitat von Edward Burr <egburr at burr.cc>:
>>> Quoting Ralf Lang <lang at b1-systems.de>:
>>>> Am 14.11.18 um 19:21 schrieb Edward Burr:
>>>>> Hi Ralf,
>>>>> Thanks for the suggestion. 'yum install php-http' installed
>>>>> php-pecl-http and now "pecl list" shows pecl_http is installed. So,
>>>>> the step 2.5 issue appears to be cleared up?
>>>>> But the step 3.1 and 3.3 issues remain.
>>>>> 3.1) During "pear install -a horde/groupware":
>>>>> Failed to download horde/Horde_Backup within preferred state "stable",
>>>>> latest release is version 1.0.0RC1, stability "beta", use
>>>>> "channel://pear.horde.org/Horde_Backup-1.0.0RC1" to install
>>>>> Failed to download pecl/sasl within preferred state "stable", latest
>>>>> release is version 0.1.0, stability "alpha", use
>>>>> "channel://pecl.php.net/sasl-0.1.0" to install
>>>>> Failed to download pecl/idn within preferred state "stable", latest
>>>>> release is version 0.2.0, stability "beta", use
>>>>> "channel://pecl.php.net/idn-0.2.0" to install
>>>>> Trying to install each manually fails.
>>>> If you are using distribution php, get the PECLs from distribution (yum).
>>>> For installing RC packages, either preinstall Horde_Backup ignoring deps
>>>> (pear install -n horde/Horde_Backup) or allow installation of  
>>>> beta software
>>>> |pear config-setpreferred_state beta|
>>>> change to stable when you are done.
>>> yum install php-sasl
>>> yum install pecl-sasl
>>> yum install pecl_sasl
>>> yum install pear-sasl
>>> yum install pear_sasl
>>> # All result in "No package XXX available. Nothing to do."
>>> yum install php-idn
>>> # installed php-idn-1.2c-12
>>> pecl install channel://pecl.php.net/idn-0.2.0
>>> # still fails with same error
>>> I uninstalled all the horde packages and pre-installed  
>>> Horde_Backup per your suggestion.
>>> pear uninstall `pear list -c horde | tail -n +4 | awk '{ print  
>>> "horde/"$1 }'`
>>> pear install -n horde/Horde_Backup-1.0.0RC1
>>> install ok: channel://pear.horde.org/Horde_Backup-1.0.0RC1
>>> Then installed horde:
>>> pear install horde/horde_role
>>> pear run-scripts horde/horde_role
>>> pear install -a horde/groupware
>>> But Horde_Core failed to install, and many components depending on  
>>> Horde_Core:
>>> horde/Horde_Core requires package "horde/Horde_Backup" (version >=  
>>> 1.0.0, version <= 2.0.0alpha1, excluded versions: 2.0.0alpha1),  
>>> installed version is 1.0.0RC1
>>> ASpparently 1.0.0RC1 isn't greater than/equal to 1.0.0 even though  
>>> that's apparently the absolute latest available:
>>> Failed to download horde/Horde_Backup within preferred state  
>>> "stable", latest release is version 1.0.0RC1, stability "beta",  
>>> use "channel://pear.horde.org/Horde_Backup-1.0.0RC1" to install
>>> How do I satisfy this requirement?
>>> The install directions appear pretty straightforward. I've got to  
>>> be missing something obvious, but I can't figure out what it could  
>>> be.
>> pear install horde/horde_backup-beta
> Among other things, that did:
> downloading Horde_Backup-1.0.0RC1.tgz ...
> Starting to download Horde_Backup-1.0.0RC1.tgz (8,518 bytes)
> .....done: 8,518 bytes
> install ok: channel://pear.horde.org/Horde_Backup-1.0.0RC1
> which leaves us still with the same problem as above.
>> -- 
>> Jan Schneider
>> The Horde Project
>> https://www.horde.org/
>> -- 
>> Horde mailing list
>> Frequently Asked Questions: http://horde.org/faq/
>> To unsubscribe, mail: horde-unsubscribe at lists.horde.org

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 4373 bytes
Desc: S/MIME Signature
URL: <https://lists.horde.org/archives/horde/attachments/20181125/57484868/attachment.bin>

More information about the horde mailing list