[imp] Compose always sending actionID == 0

Andreas Aardal Hanssen andreaha-imp@lexx.infeline.org
Sun, 2 Jun 2002 21:30:00 +0200 (CEST)


I'm using imp-3.1rc3, and horde 2.0, with php 4.1.2 on a RH7.2 box. I ran 
3.0 for a while, worked fine. When I upgraded to 3.1rc3, everything still 
works fine except "compose".

When I press "Compose", all buttons in this window (Send, attach, special 
characters, spell) submit $actionID == 0 in compose.php.

This means that NO_ACTION is passed to the switch-case-thingo (I'm no good 
with php), and nothing happens. For instance, if I type in a mail and 
press "Send Mail", the form just gets blanked and nothing happens.

$conf['mailer']['type'] = 'sendmail';
$conf['mailer']['params'] = array();
$conf['mailer']['params']['sendmail_path'] = '/usr/sbin/sendmail';

These settings shouldn't be relevant, because of NO_ACTION causing the
actual send_mail code never to be reached. This is from compose.php:

/* Run through the action handlers. */
$ACTION_TEXT = _("Compose a message");
switch ($actionID) {
 case NO_ACTION:

At this point, $actionID is always 0 no matter what I press in the compose 

If anyone wants to check this out, please visit
http://www.infeline.org/horde/imp . For a user name or password, please
send me a personal mail at this (From:) address.

I'm also experiencing an error when logging out (unrelated?):

Warning: Constant sid already defined in /var/www/html/horde/lib/Prefs.php
on line 91

Warning: Cannot send session cache limiter - headers already sent (output
started at /var/www/html/horde/lib/Prefs.php:91) in
/var/www/html/horde/lib/Prefs.php on line 91

Hope someone can help me. Do you need more info? The log file
/tmp/horde.log shows only "login succeeded" and "logout succeeded" and
"session expired" (session expired only after a considerable amout of
time, and not related to the sending of mail). Log mode is set to DEBUG.


-- Andreas Aardal Hanssen