[imp] Compose always sending actionID == 0

Andreas Aardal Hanssen andreaha-imp@lexx.infeline.org
Sun, 2 Jun 2002 21:56:18 +0200 (CEST)

On Sun, 2 Jun 2002, Jim Hale wrote:
>Scott Bigelow had helped me solve something similar when I first started
>- here's what he said to do:
>> > go to horde/imp/templates/compose/compose.inc
>> > go to line 12 (i think)
>> > delete 'enctype="multipart/form-data" ' from the FORM tag.
>He said it had something to do with the way that Apache did things.
>Hope this helps. :)

Thanks, it worked! :-)


>Jim Hale
>Jim & Kathy's Website Collection
>-----Original Message-----
>From: imp-bounces@lists.horde.org [mailto:imp-bounces@lists.horde.org]
>On Behalf Of Andreas Aardal Hanssen
>Sent: Sunday, June 02, 2002 2:30 PM
>To: IMP
>Subject: [imp] Compose always sending actionID == 0
>I'm using imp-3.1rc3, and horde 2.0, with php 4.1.2 on a RH7.2 box. I
>3.0 for a while, worked fine. When I upgraded to 3.1rc3, everything
>works fine except "compose".
>When I press "Compose", all buttons in this window (Send, attach,
>characters, spell) submit $actionID == 0 in compose.php.
>This means that NO_ACTION is passed to the switch-case-thingo (I'm no
>with php), and nothing happens. For instance, if I type in a mail and 
>press "Send Mail", the form just gets blanked and nothing happens.
>$conf['mailer']['type'] = 'sendmail';
>$conf['mailer']['params'] = array();
>$conf['mailer']['params']['sendmail_path'] = '/usr/sbin/sendmail';
>These settings shouldn't be relevant, because of NO_ACTION causing the
>actual send_mail code never to be reached. This is from compose.php:
>/* Run through the action handlers. */
>$ACTION_TEXT = _("Compose a message");
>switch ($actionID) {
> case NO_ACTION:
>At this point, $actionID is always 0 no matter what I press in the
>If anyone wants to check this out, please visit
>http://www.infeline.org/horde/imp . For a user name or password, please
>send me a personal mail at this (From:) address.
>I'm also experiencing an error when logging out (unrelated?):
>Warning: Constant sid already defined in
>/var/www/html/horde/lib/Prefs.php on line 91
>Warning: Cannot send session cache limiter - headers already sent
>(output started at /var/www/html/horde/lib/Prefs.php:91) in
>/var/www/html/horde/lib/Prefs.php on line 91
>Hope someone can help me. Do you need more info? The log file
>/tmp/horde.log shows only "login succeeded" and "logout succeeded" and
>"session expired" (session expired only after a considerable amout of
>time, and not related to the sending of mail). Log mode is set to DEBUG.
>-- Andreas Aardal Hanssen

Andreas Aardal Hanssen