[imp] cannot see attachments within a pgp signed message

Benoit St-André ben at benoitst-andre.net
Mon Sep 6 19:40:43 PDT 2004

Chuck Hagenbuch a écrit :
> Quoting Benoit St-André <ben at benoitst-andre.net>:
>> Does it still work with the two other attachments (testing.doc and
>> testing.sxw) ? I attached also the other patch to see the difference. I
>> tried reposting that message to my Horde install, and it is still not
>> working.
> Hmm, IMP only shows me the inline attachment. Jan, any idea where to 
> look for
> the difference with you?
> -chuck
> -- 
> "Regard my poor demoralized mule!" - Juan Valdez

I just found the difference with us and Jan.

In IMP's preferences, in "message options", "message viewing", the 
preference for displaying the attachments is causing behavior.

Choosing "Listing in the Header" causes the bug we have of not seeing 
the other attachements.

$_prefs['attachment_display'] => 'list' (NOT OK)

The other two (inline and both) are working well. Jan probably one of 
those settings on.

My collegue who helped me to discover the bug explained that the way 
attachments where treated with pgp where probably causing this, since 
the attachments are "embedded" whithin the pgp signature (the 
multipart/signed contains some multipart/mixed, ...).

Hope it helps
Benoit St-André
ben at benoitst-andre.net
Connaissez-vous Linuxédu-Québec ? http://linuxeduquebec.org
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: OpenPGP digital signature
Url : http://lists.horde.org/archives/imp/attachments/20040906/f3c41dbb/signature.bin

More information about the imp mailing list