[ingo] Error (redeclaration of Text) in latest CVS

Roel Gloudemans roel at gloudemans.info
Sun Dec 14 07:50:09 PST 2003

> Message: 2
> Date: Sat, 13 Dec 2003 17:51:02 +0100
> From: Jan Schneider <jan at horde.org>
> Subject: Re: [ingo] Error (redeclaration of Text) in latest CVS
> 	version
> To: ingo at lists.horde.org
> Message-ID: <20031213175102.hwwgc4s0w4sg80oc at neo.wg.de>
> Content-Type: text/plain; charset="ISO-8859-15"
> Zitat von Roel Gloudemans <roel at gloudemans.info>:
> > Hi,
> >
> > I just installed the latest CVS version of Ingo on an PHP 4.3.X box and a
> > PHP
> > 4.2.X box.
> >
> > Ingo worked fine on PHP 4.3, but I had to make the following modification
> > for
> > Ingo to work on the PHP 4.2.X box.
> >
> > In ingo/lib/base.php remove the line:
> > require_once HORDE_LIBS . 'Horde/Text.php';
> >
> > and add it to ingo/lib/Ingo.php, below the line:
> > function flistSelect($value = null, $form = null, $tagname =
> > 'actionvalue')
> > {
> >
> > Now it works on both boxes.
> This makes absolutely no sense.
> Jan.

I know, that's why it took me a long time to find out. The test box is the 4.3.X
system and Ingo worked perfectly right out of CVS. However, it wouldn't work on
the 4.2.X system (Updated the Horde framework at the same time at both
systems). It kept giving me error messages about the redeclaration of Text. So
I removed the require_once lib/Text.php. It worked the, except for adding rules
which redirected mail to another mail folder. I added the require_once in that
particular function and everything worked.

Some more info: 4.3.X box is Fedora Core 1. 4.2.X box is RedHat 9. In both cases
PHP is configured in the standard way. I use Turck-mmcache for PHP caching, but
I flushed the cache several times and even rebooted and switched it off.

As a sidenote, I haven't got a clue about how Horde is built and what goes where
(I have PHP experience though). That's still a future project.


More information about the ingo mailing list