[ingo] Endless loop...?

vljubovic at smartnet.ba vljubovic at smartnet.ba
Fri Apr 16 01:18:08 PDT 2004

Hello list!

I just tried to use Ingo 1.0 alpha with Horde 3.0 alpha and IMP 3.0 alpha. When
I try to open my mailbox, the browser just spins indefinitely without opening
and then after a minute or so I get a message from browser, something like "The
connection terminated unexpectedly".

horde.log contains nothing (set to PEAR_LOG_NOTICE)
Apache access_log also contains nothing. But Apache error_log contains megabytes
upon megabytes of following messages:

[client] PHP Notice:  Undefined index:  delimiter in
/srv/www/htdocs/horde/imp/lib/Folder.php on line 203, referer:
[client] PHP Warning:  implode(): Bad arguments. in
/srv/www/htdocs/horde/imp/lib/Folder.php on line 203, referer:
[client] PHP Warning:  array_pop(): The argument should be an
array in /srv/www/htdocs/horde/imp/lib/Folder.php on line 218, referer:

Followed by a single message:

Allowed memory size of 31457280 bytes exhausted (tried to allocate 10240 bytes)

Note that if I set memory_limit to more than 30M in php.ini, all of it will be
eaten nevertheless.

Attached is my backends.php

I know that it's probably wrong, but I still think it's a bug for Ingo to hang
in such an ungracefull way. I would also like to know what did I do wrong ;)

Thanks for your replies!
-------------- next part --------------
A non-text attachment was scrubbed...
Name: backends.php
Type: application/x-php
Size: 3273 bytes
Desc: not available
Url : http://lists.horde.org/archives/ingo/attachments/20040416/3c27ecef/backends.bin

More information about the ingo mailing list