[ingo] Strange Sieve Problem

Darron Froese darron at nonfiction.ca
Thu Jul 27 14:48:14 PDT 2006

System: RHEL 4, Apache 2.0.52 w/PHP 4.3.9
Setup: Horde: 3.1.2, Imp: H3 (4.1.2), Ingo: H3 (1.1.1), SAM 0.1-cvs

Basic summary: I cannot authenticate my users to the Sieve server  
through Ingo unless their password is the same as the cyrus admin user.

I applied this patch - because I was having problems after enabling  
TLS and nothing worked at all:


Now, my user works - because the password for me and the cyrus admin  
user is the same - no other usernames work with saving sieve rules to  
the server through Ingo - but they can all connect just fine with  
sivtest and sieveshell.

I just tried with the user bob and got this from Ingo:

Jul 27 15:40:26 fenring sieve[4037]: badlogin: localhost.localdomain 
[] PLAIN authentication failure

But I can log in through IMP and sivtest just fine:

[root at fenring darron]# sivtest -u bob -a bob localhost
S: "IMPLEMENTATION" "Cyrus timsieved v2.3.7-Invoca-RPM-2.3.7-2"
S: "SIEVE" "comparator-i;ascii-numeric fileinto reject vacation  
imapflags notify envelope relational regex subaddress copy"
Please enter your password:
Security strength factor: 0

That's with his normal password - if I change the password to be the  
same as the cyrus admin user, it works fine here and in Ingo:

Jul 27 15:45:47 fenring sieve[4412]: login: localhost.localdomain 
[] bob PLAIN User logged in

Does it have something to do with the "-a" flag in sivtest and  
sieveshell? Is there any way to make Ingo use it?

Anyone else seen this?
darron froese
nonfiction studios inc.
t  403.686.8887
c 403.819.7887
f  403.313.9233
w http://nonfiction.ca/
e  darron at nonfiction.ca

More information about the ingo mailing list