[ingo] Ingo&Maildrop

Staff Forwarding staff at 4xtra.com
Thu Aug 21 15:04:50 UTC 2014

On 19/08/2014 11:51, Ralf Lang wrote:
> On 19.08.2014 12:49, Staff Forwarding wrote:
>> Ii have a functioning Horde system with a Postfix/Courier mail server.
>> I've only just got around to adding Maildrop filtering on the server
>> side & now wish to link Ingo to Maildrop.
>> I've put the (what I believe to be) correct values into the backends.php
>> & as I have virtual users created a new horde ftp user & added its
>> details to hook.php
>> I can add and edit rules through Horde, but nothing is added to my
>> mailfilter file. It could be permissions (of course) but I can't even
>> see that the Maildrop .php is being invoked.
>> So, (a) any obvious pointers and (b) is there any way to trace the
>> activity which occurs when I click save so that I can track down what
>> I've done wrong?
>> /Chris
> You generally do not edit backends.php
I only changed the disabled to false & uncommented the lines for maildrop
> Have you tried retrieving the currently installed rule set in the ingo
> UI or manually forcing a rewrite of the rules?
> /ingo/basic.php?page=script
  I have tried this & I get an authentication failure on my FTP login.

Checking my auth logs, it is not using the credentials from hooks.php, 
but still trying to log into FTP using the mail user, e.g. "chris.hogan" 
not my FTP specified by hooks.php - I assume that my error is there. The 
section looks like:

     public function transport_auth($driver)
         switch ($driver) {
         case 'maildrop':
             // configured for my ftp access
             return array(
               // The VFS username to use
               'username' => 'horde',
               // The VFS password to use
               'password' => 'XXXXXXXXXXXXXXXXX'

         // DEFAULT: Use hordeauth (identical to not defining hook at all).
         return true;

I have tested the user manually by logging in with another FTP client: 
its permissions are correct & I can upload a test file, so I;'m guessing 
that I'm just failing to pass the correct details to Ingo

More information about the ingo mailing list