[ingo] problem writing sieve file

Ted ted at easydns.com
Mon Dec 16 18:55:57 UTC 2019


I'm working on a horde implementation for our mail system, and I'm 
having problems with getting ingo to be able to write to the sieve file 
to the server, I get a connection time out error whenever I try to save 
a filter.  Horde can access email on the same server it's trying to 
write the file to, and all other functions seem to work.

My backends.local.php is as below:

$backends['imap']['disabled'] = true;
$backends['sieve']['disabled'] = false;
$backends['sieve']['transport'][Ingo::RULE_ALL]['params']['hostspec'] = 
$backends['sieve']['script'][Ingo::RULE_ALL]['params']['utf8'] = true;

That mailservers are loadbalanced and also run through a director proxy, 
so the imap.easymail.ca host points to a loadbalanced director-dovecot 
cluster which handles login requests and directs to the backend servers 
which actually maintain the mail and sieve files, I had tried having 
ingo connect  directly to one of the director machines and directly to 
one backend server to see if something in the networkng was a problem, 
but I get the same result regardless.  I'm wondering if there is 
something needed in the config I'm unaware of, or what else to check at 
this point.  Can anyone offer any insight or suggestions?

easyDNS Technologies

More information about the ingo mailing list