[Tickets #12486] Re: Can't download attachments over ActiveSync

noreply at bugs.horde.org noreply at bugs.horde.org
Sat Jul 27 13:36:40 UTC 2013


Ticket URL: http://bugs.horde.org/ticket/12486
  Ticket             | 12486
  Updated By         | Michael Rubinsky <mrubinsk at horde.org>
  Summary            | Can't download attachments over ActiveSync
  Queue              | Synchronization
  Version            | Git master
  Type               | Bug
  State              | Not A Bug
  Priority           | 1. Low
  Milestone          |
  Patch              |
  Owners             |

Michael Rubinsky <mrubinsk at horde.org> (2013-07-27 13:36) wrote:

> I am now running php 5.3.27, which was released Jul 19, 2013.
> The errors still occur, I still cannot download large attachments  
> over ActiveSync, and I still get:
> [Sat Jul 27 18:37:06 2013] [notice] child pid 13855 exit signal  
> Segmentation fault (11)

Segmentation faults are *never* the fault of userland php code. They  
are caused by internal errors in PHP (or less likely, the webserver).

> zend_mm_heap corrupted
> zend_mm_heap corrupted

This means the memory manager has crashed and is likely due to some  
buggy PHP module. Do you have APC or other opcode cache running? Try  
disabling ALL non-essential php/pecl modules. If that doesn't work -  
you could try using something like GDB to attach to the apache  
process, wait for the crash,  and see if you can get any meaningful  
data out of the output.

> The STREAM appears to work fine according to the AS device log  
> (13939 is the PID to follow):

What makes you say that? That is *exactly* where this is failing. The  
'[stream]' text is output to the logfile immediately before the stream  
processing begins. Something is crashing immediately after '[stream]'  
is output to the log, but before the closing Wbxml tag is output to  
the log. The *only* thing that occurs between these two events is  
stream processing.

Not what you want to hear, but something is broken/buggy on your  
system. So far you are the only person reporting this, and no other  
dev can reproduce it.

> I haven't reset device AS partnerships or anything, just tried to  
> open an attachment on an email already on my wife's iPhone.

That shouldn't make a difference.

More information about the bugs mailing list