[dev] Re: [cvs] commit: framework/Auth Auth.php framework/Auth/Auth application.php customsql.php cyrsql.php cyrus.php imap.php ldap.php sql.php

Jan Schneider jan at horde.org
Thu Jun 10 03:47:34 PDT 2004

Zitat von Chuck Hagenbuch <chuck at horde.org>:

> Quoting Jan Schneider <jan at horde.org>:
>>   Log:
>>   Add framework to remove all user data from applications when a user gets
>>   removed from the authentication backend. What's left to do is to implement
>>   "removeuser" methods in the APIs, e.g. to remove prefs, calendars, shares,
>>   permissions, etc.
> Any objection to making the method name "removeUser" instead? Just a bit more
> consistent with our other stuff.

I chose removeuser at first because we have that as an API method already
(for the application auth driver). But I agree, we should rename it, as
well as the other methods (adduser etc.).

>>   We might want to allow this even for auth backends that don't 
>> support   removing of users, either by implementing 
>> Auth::removeUser() or by making
>>   Auth::_removeUser() public.
> Making _removeUser into a public removeUser() method sounds right to me.

There already is a public removeUser() that only returns a PEAR_Error
"unsupported". As this (being unsupported) is still true for most auth
drivers, we could perhaps remove the user data and return a PEAR_Error
"User data removed but not the user himself" or some such. Thoughts?


Do you need professional PHP or Horde consulting?

More information about the dev mailing list