[dev] Re: [cvs] commit: framework/Auth Auth.php framework/Auth/Auth application.php customsql.php cyrsql.php cyrus.php imap.php ldap.php sql.php

Chuck Hagenbuch chuck at horde.org
Thu Jun 10 06:38:51 PDT 2004

Quoting Jan Schneider <jan at horde.org>:

> I chose removeuser at first because we have that as an API method already
> (for the application auth driver). But I agree, we should rename it, as
> well as the other methods (adduser etc.).

Sounds good.

> There already is a public removeUser() that only returns a PEAR_Error
> "unsupported". As this (being unsupported) is still true for most auth
> drivers, we could perhaps remove the user data and return a PEAR_Error
> "User data removed but not the user himself" or some such. Thoughts?

Ah, right. How about having Auth::removeUserData() (and making the registry
method match that name), which gets called by default by Auth::removeUser()
(though perhaps adding an option to not do it?).


"Regard my poor demoralized mule!" - Juan Valdez

More information about the dev mailing list