[horde] rpm install question db2_dba

Tim Olson tim at 5000feet.com
Wed Jan 23 20:34:35 PST 2002

I thought I'd recap for you all just for the archives...
I hope I tell the story in the right order, but here goes.
I am using redhat 6.2 for Sparc, by the way.

I was having db2_dba failures when I was trying to rebuild the
redhat 6.2 SRPM to install on my system.  It wouldn't rebuild,
and the source wouldn't install the way it was.

A great guy named Brent gave me the tip that since I wasn't using
db2, I could add --without-db2 to my php.spec file.  So I did
that and I did an "rpm -ba php.spec" from the /usr/src/redhat/SPECS
directory.   Out came an RPM that I installed.  It supposedly
had IMAP support, and I think it really THOUGHT it did, because
it did create /usr/lib/php3/imap.so and put all the right things
in my /etc/httpd/conf/httpd.conf file and everything.
BUT, when I ran the "../test.php3" script, it said there was no
IMAP support.  So, I added the line --with-imap to my .spec
file and did it again.

This time when I tried starting Apache, it gave me errors regarding
"gss_nt_service_name" which is related to kerberos and PHP I guess.
So, I added --without-kerberos and rebuilt the RPM one more time.

This time I tried to fire up Apache and I got more errors 
regarding "gss_mech_krb5".  This is more Kerberos stuff. 
I hit the jackpot though when I saw someone who said that on
redhat 6.1 they had this error.  Here is their comment:

"add a line "export LD_PRELOAD=/usr/kerberos/lib/libgssapi_krb5.so" 
before you start the daemon in your /etc/rc.d/init.d/httpd file
This helps on my system (RH6.1)."

So, I put that line in, and sure enough Apache fired up with
no problem.  Then I went to test.php3 and it showed IMAP support,
and MySQL support (that's the database I chose)  So, I figured I
was all set, but when I went to log in, it just timed out.

So, I restarted httpd, and mysql daemons and then it all came to
life with no problem!

I did end up recompiling my qpopper with  "--enable-uw-kludge"
to get rid of an annoying message I got every time I was in and
out of webmail, but it now works!

So, Brent, thanks for your tips and support, and I just hope it
goes smoother for you folks running intel machines.  I doubt people
had as much trouble on the newer platforms.


More information about the horde mailing list