[horde] (no subject)

Michael J. Pelletier mjpelletier at mjpelletier.com
Sat Mar 6 10:44:24 PST 2004

Eric, this is not my problem. The PHP binary IS located at /usr/local/bin/php...
I have been running this for quite some time. It was just recently changed. This
is what was added to the top of horde/framework/install-packages.php:

/* Don't die if time limit exceeded. */

/* Get any arguments. */
require_once 'Console/Getopt.php';
$args = Console_Getopt::readPHPArgv();
$options = Console_Getopt::getopt($args, 'd:c:', array('install-dir=',
if (PEAR::isError($options)) {
    echo "Bad option\n";

/* Set these options to empty by default. */
$install_dir = '';
$config_file = '';
foreach ($options[0] as $option) {
    switch ($option[0]) {
    case 'd':
    case '--install-dir':
        /* Alternate install directory requested. */
        $install_dir = ' -d php_dir=' . $option[1] .
                       ' -d test_dir=' . $option[1] . '/tests' .
                       ' -d doc_dir=' . $option[1] . '/doc' .
                       ' -d data_dir=' . $option[1] . '/data';
    case 'c':
    case '--config':
        /* Alternate config file requested. */
        $config_file = ' -c ' . $option[1];

It appears to me thast is failing at the new statement
$options = Console_Getopt::getopt($args, 'd:c:', array('install-dir=',
if (PEAR::isError($options)) {
    echo "Bad option\n";

Not sure what the 'd:c:' is for but this is more of a windows drive letter
thing. I am NOT using windows...


Quoting "Michael J. Pelletier" <mjpelletier at mjpelletier.com>:

> After sync'ing today I tried to update the packages via
> horde/framework/install-packages.php. However, I got a message of
> "#!/usr/local/bin/php Bad option". Has anyone else got the same result?

Either run it via the php command, or modify the path in the first
line of the file to point to your php command line program (e.g.

> Michael

-- Eric Rostetter

This message was sent using IMP, the Internet Messaging Program.

More information about the horde mailing list