[horde] Horde and MySQL problem

Thomas O'Brien thomas at creativebusinessystems.com
Sat May 8 18:47:47 PDT 2004


I'll give this another shot, however I don't know how the CVS head compares
to the version you're running.

I believe that horde.php was replaced by conf.php in HEAD. Here's what I
have in the pertinent sections of my conf.php:

$conf['sql']['phptype'] = 'mysql';
$conf['sql']['persistent'] = false;
$conf['sql']['protocol'] = 'tcp';
$conf['sql']['hostspec'] = 'localhost';
$conf['sql']['username'] = 'horde';
$conf['sql']['password'] = '*****!';
$conf['sql']['database'] = 'horde';
$conf['sql']['charset'] = 'iso-8859-1';

$conf['auth']['admins'] = array('someone at mydomain.com');
$conf['auth']['checkip'] = false;
$conf['auth']['params']['app'] = 'imp';
$conf['auth']['driver'] = 'application'; 

$conf['sessionhandler']['params']['persistent'] = false;
$conf['sessionhandler']['params']['port'] = 5432;
$conf['sessionhandler']['params']['protocol'] = 'tcp';
$conf['sessionhandler']['params']['hostspec'] = 'localhost';
$conf['sessionhandler']['params']['username'] = 'horde';
$conf['sessionhandler']['params']['password'] = '*****!';
$conf['sessionhandler']['params']['database'] = 'horde';
$conf['sessionhandler']['type'] = 'mysql';


-----Original Message-----
From: Adam Kuklycz [mailto:adamk at mcservices.com.au] 
Sent: Saturday, May 08, 2004 6:12 PM
To: thomas at creativebusinessystems.com
Cc: horde at lists.horde.org
Subject: RE: [horde] Horde and MySQL problem

Ok I've tried setting the password to things that are plain and simple such
as username horde password horde and it still does not work.

Just to follow up on your saying you use CVS HEAD I found a script in there
called auth_initial_user.sql which I ran to create an admin user.

I got the same error after running that as well.

Sorry to be a pain guys just I am determined to get this initial user in and
running, as I know how powerful horde, in conjunction with modules like IMP,
Turba etc can be, I am very keen to muck around with it much more!!

Thanks again!

-----Original Message-----
From: Thomas O'Brien [mailto:thomas at creativebusinessystems.com]
Sent: Sunday, 9 May 2004 2:41 AM
To: 'Adam Kuklycz'
Cc: horde at lists.horde.org
Subject: RE: [horde] Horde and MySQL problem

I use CVS HEAd so maybe this is a stupid question, but... Did you specify a
new password in the mysql_create.sql before executed it?

Just a thought

-----Original Message-----
From: horde-bounces at lists.horde.org [mailto:horde-bounces at lists.horde.org]
On Behalf Of Adam Kuklycz
Sent: Saturday, May 08, 2004 5:12 AM
To: horde at lists.horde.org
Subject: [horde] Horde and MySQL problem

Hi all

I've been working on an upgrade to horde/imp/turba/kronolith today and
trying to upgrade the versions to current.  My production setup of horde is
getting old and I'm keen to get some nice new features up and running.

This time around I am trying to get horde 2.2.5 installed and using the
MySQL database that is running on the local machine.

However everytime I try to log in a user, it keeps showing up as:

Required 'phptype' not specified in authentication configuration.

[line 97 of /pub/web/horde/lib/Auth/sql.php]

Details have been logged for the administrator.

So I checked horde.php and ensured the following (after reading this list
time and time again):

$conf['auth']['driver'] = 'sql';
$conf['auth']['params'] = array();

And in preferences section -->

$conf['prefs']['driver'] = 'sql';
$conf['prefs']['params'] = array();
$conf['prefs']['params']['phptype'] = 'mysql';
$conf['prefs']['params']['hostspec'] = 'localhost';
$conf['prefs']['params']['username'] = 'horde';
$conf['prefs']['params']['password'] = 'horde';
$conf['prefs']['params']['database'] = 'horde';
$conf['prefs']['params']['table'] = 'horde_prefs';

With that, it didn't work.  I used the mysql_create.sql file to create the
database and tables and double checked them against the configs as mentioned

So digging deeper I tried uncommenting -->

$conf['sessionhandler']['params'] = array();
$conf['sessionhandler']['params']['phptype'] = 'mysql';
$conf['sessionhandler']['params']['hostspec'] = 'localhost';
$conf['sessionhandler']['params']['username'] = 'horde';
$conf['sessionhandler']['params']['password'] = 'horde';
$conf['sessionhandler']['params']['database'] = 'horde';

Obviously replacing the password with something other than horde in all

Can anyone please help me with this problem?  What am I missing here?

Adam Kuklycz

Horde mailing list - Join the hunt: http://horde.org/bounties/#horde
Frequently Asked Questions: http://horde.org/faq/ To unsubscribe, mail:
horde-unsubscribe at lists.horde.org

More information about the horde mailing list