[horde] Issues logging into horde...

kyurick@ericotech.net kyurick at ericotech.net
Thu Jul 7 15:05:53 PDT 2005


Working on an email server for my one job site.  The OS is Redhat 9.  I've got
apache 1.3.33 running for the webserver.  I've got horde v. 2.28 for the
framework with all sub components needed installed.  I've also installed imp
3.2.8 and turba 1.2.5.  Mysql 4.0 running for my database.. 

If i goto /horde/test.php my stats are as follows:

Horde Versions

    * Horde: 2.2.8
    * IMP: 3.2.8 (run IMP tests)
    * Turba: 1.2.5

PHP Version

    * View phpinfo() screen
    * PHP Version: 4.2.2
    * PHP Major Version: 4.2
    * PHP Minor Version: 2
    * PHP Version Classification: release
    * You are running a supported version of PHP.

PHP Module Capabilities

    * DOM XML Support: Yes
    * FTP Support: Yes
    * Gettext Support: Yes
    * IMAP Support: Yes
    * LDAP Support: Yes
    * MCAL Support: No
    * Mcrypt Support: No
    * MySQL Support: Yes
    * PostgreSQL Support: Yes
    * XML Support: Yes

Miscellaneous PHP Settings

    * magic_quotes_runtime disabled: Yes
    * file_uploads enabled: Yes
    * safe_mode disabled: Yes
    * trans_sid disabled: No
    * Horde will work with session.trans_sid turned on, but you may see double
session-ids in your URLs, and if the session name in php.ini differs from the
session name configured in Horde, you may get two session ids and see other odd
behavior. The URL-rewriting that trans_sid does also tends to break XHTML

PHP Sessions

    * Session counter: 2
    * To unregister the session: click here


    * PEAR - Yes
    * Recent PEAR - Yes
    * Mail - Yes
    * Log - Yes
    * DB - Yes
    * Net_Socket - Yes
    * Date - Yes
    * HTML_Common/HTML_Select - Yes

everything looks good there to me...

I ran the mysql_create.sql file.  Verified that the database was made by logging
into it with the horde account made by the scryp.  

I want it setup to authenticate through mysql.  i know that there's alot of info
regarding this on the site.. searched archives and found some good info.  Only,
i'm still not up and running..  authentication in my horde.php is as follows:

$conf['auth']['driver'] = 'sql';

// An array holding any parameters that the Auth object will need to
// function correctly.
$conf['auth']['params'] = array();
$conf['auth']['params']['phptype'] = 'mysql';
$conf['auth']['params']['hostspec'] = 'mail.pinnaclenissan.com';
$conf['auth']['params']['username'] = 'root';
$conf['auth']['params']['password'] = '';
$conf['auth']['params']['database'] = 'horde';
$conf['auth']['params']['table'] = 'horde_users';

the username & password are correct the hostname of my pc is

// What preferences driver should we use? Valid values are 'none'
// (meaning use system defaults and don't save any user preferences),
// 'session' (preferences only persist during the login), 'ldap',
// and 'sql'.
$conf['prefs']['driver'] = 'sql';

a little further down i un-remd' these lines:

   $conf['prefs']['params']['phptype'] = 'mysql';
   $conf['prefs']['params']['hostspec'] = 'mail.pinnaclenissan.com';
   $conf['prefs']['params']['username'] = 'root';
   $conf['prefs']['params']['password'] = '';
   $conf['prefs']['params']['database'] = 'horde';
   $conf['prefs']['params']['table'] = 'horde_prefs';
as with this...

 $conf['sessionhandler']['params'] = array();
   $conf['sessionhandler']['params']['phptype'] = 'mysql';
   $conf['sessionhandler']['params']['hostspec'] = 'mail.pinnaclenissan.com';
   $conf['sessionhandler']['params']['username'] = 'root';
   $conf['sessionhandler']['params']['password'] = '';
   $conf['sessionhandler']['params']['database'] = 'horde';

in the registry.php file i un-remd' the two lines for imp authentication (should
it be used?)
$this->registry['auth']['login'] = 'imp';
$this->registry['auth']['logout'] = 'imp';

ok, now to the problem at hand.  much like many other posters, i've got a weird
problem w/ logging into the main horde framework.  When i type in horde for the
username & password i returns to the login screen.  when i check the horde log
file, i get...

Jul 07 14:36:29 HORDE [error] [imp] FAILED LOGIN to
mail:143[imap/notls] as horde [on line 287 of
(I figure i should rem out the two lines in registry.ini to get this error gone).

when i rem the lines out i get this error..

Jul 07 14:25:00 HORDE [error] [horde] FAILED LOGIN for horde [] to
Horde [on line 48 of "/var/www/html/horde/login.php"]

I've opened up login.php.  line 48 "     Horde::logMessage($entry, __FILE__,
__LINE__, $level); "  

What the hell does this mean?  This is kind of where i'm stuck.  Any help would
be greatly appreciated.


More information about the horde mailing list