[horde] Can't get Horde to Work At All

Antonio DeLaCruz adelacruz1 at kc.rr.com
Sat Aug 12 01:49:47 PDT 2006

I can't get Horde to work at all for some reason.  I get the same error
message over and over and over again.  I'm not sure if it's something in my
php.ini file, or httpd.conf file, or what.  I've been searching around the
internet all week for the answer and have only found a couple of other
people that have experienced the same issue.  They seemed to be having an
issue like this with PHP 4 and they fixed it using domxml.  But as far as
this specific error, nobody has been able to answer what is going on.
Now, I have only attempted to install Horde, and this is what I get when I
bring it up in a browser:
Notice: Undefined index: log in /e-mail/lib/Horde.php on line 49

A fatal error has occurred

Registry objects should never be cloned.

Details have been logged for the administrator.

Any help on this would be much appreciated.  I'm getting so frustrated I'm
thinking of just going and buying @mail or putting something like
squirrelmail on and buying templates from nutsmail.com.  I used to have
Horde running on my other system and it was perfect.  It did everything that
I needed and more.  Time for more coffee.....
I did a fresh install this past weekend of everything.
Slackware 10.2 running kernel
Apache 2.2.3
PHP 5.1.4
Horde 3.1.2
UW Imap 2004g
MySQL 14.7 Distrib 4.1.14
PostgreSQL 8.1.4   I'm trying to use PostgreSQL as my back end.
Pear 1.4.10
Zend Engine 2.1.0
Here is my config for Apache:
./configure --prefix=/apache --enable-inline-optimization --disable-userdir
--enable-deflate --enable-headers --enable-mime-magic --enable-so --with-z
Here is my config for php:
./configure --prefix=/php --with-apxs2=/apache/bin/apxs
--with-config-file-path=/php --enable-calendar --with-gd --with-gettext
--with-jpeg-dir --with-png-dir --with-imap=/installs/e-mail/imap-2004g
--with-mysql=/mysql --with-pgsql=/postgres/bin --with-zlib-dir --with-iconv
--with-dom --with-xml --with-mcrypt --enable-mbstring=all --enable-mbregex
--with-mime-magic --with-openssl --with-ftp --enable-ctype --with-mhash
Here is my Pear listing:
Installed packages, channel pear.php.net:
Package        Version State
Archive_Tar    1.3.1   stable
Cache          1.5.4   stable
Console_Getopt 1.2     stable
DB             1.7.6   stable
Date           1.4.6   stable
File           1.2.2   stable
Fileinfo       1.0.3   stable
HTTP_Request   1.3.0   stable
Log            1.9.8   stable
MDB2           2.2.0   stable
Mail           1.1.10  stable
Mail_Mime      1.3.1   stable
Net_SMTP       1.2.8   stable
Net_Socket     1.0.6   stable
Net_URL        1.0.14  stable
PEAR           1.4.10  stable
PHPUnit        1.3.2   stable
XML_Parser     1.2.7   stable
XML_RPC        1.5.0   stable
XML_Serializer 0.18.0  beta
XML_Util       1.1.1   stable
memcache       2.0.4   stable

Here is the output from test.php:

Horde Version

*	Horde: 3.1.2 

Horde Applications

*	Horde: 3.1.2 

PHP Version

*	View
phpinfo() screen 

*	View
loaded extensions 

*	PHP Version: 5.1.4 

*	PHP Major Version: 5.1 

*	PHP Minor Version: 4 

*	PHP Version Classification: release 

*	You are running a supported version of PHP. 

PHP Module Capabilities

*	Ctype Support: Yes 

*	DOM XML Support: Yes 

*	FTP Support: No 

*	GD Support: Yes 

*	Gettext Support: Yes 

*	Iconv Support: Yes 

*	IMAP Support: Yes 

*	LDAP Support: No 

*	Mbstring Support: Yes 

*	Mcrypt Support: Yes 

*	MIME Magic Support (fileinfo): Yes 

*	memcached Support (memcache): Yes 

*	MIME Magic Support (mime_magic): Yes 

*	MySQL Support: Yes 

*	OpenSSL Support: Yes 

*	PostgreSQL Support: Yes 

*	Session Support: Yes 

*	XML Support: Yes 

*	Zlib Support: Yes 

Miscellaneous PHP Settings

*	magic_quotes_runtime disabled: Yes 

*	memory_limit disabled: Yes 

*	safe_mode disabled: Yes 

*	session.use_trans_sid disabled: Yes 

*	session.auto_start disabled: Yes 

File Uploads

*	file_uploads enabled: Yes 

*	upload_tmp_dir: /http/uploads 

*	upload_max_filesize: 200M 

*	post_max_size: 8M 

Required Horde Configuration Files

*	config/conf.php: Yes 

*	config/mime_drivers.php: Yes 

*	config/nls.php: Yes 

*	config/prefs.php: Yes 

*	config/registry.php: Yes 

PHP Sessions

*	Session counter: 2 

*	To unregister the session: click here


*	PEAR Search Path (PHP's include_path):

*	PEAR: Yes 

*	Recent PEAR: Yes 

*	Mail: Yes 

*	Mail_Mime: Yes 

*	Log: Yes 

*	DB: Yes 

*	Net_Socket: Yes 

*	Date: Yes 

*	Auth_SASL: No
Horde will work without the Auth_SASL class, but if you use Access Control
Lists in IMP you should be aware that without this class passwords will be
sent to the IMAP server in plain text when retrieving ACLs. 

*	HTTP_Request: Yes 

*	File: Yes 

*	Net_SMTP: Yes 

*	Services_Weather: No
Services_Weather is used by the weather applet/block on the portal page. 

*	Cache: Yes 

*	XML_Serializer: Yes

More information about the horde mailing list