[horde] attachment corrupted when uploaded via webmail and firefox

D G Teed donald.teed at gmail.com
Tue Mar 23 12:20:23 UTC 2010

I've researched this issue and tried various solutions
alluded to within problem and bug reports.

Most discussions refer back to this bug report
surrounding the quoted-printable versus base64
style of upload for buggy browsers.


In that report, the bug reporter says there is
a solution for them by disabling mime_magic
and fileinfo modules in php and letting
the reference to the mime.magic file in
the conf do the trick.

I've tried various combinations of this, restarting apache each time,
and I always find the uploaded file is corrupted by webmail.

The file extension we are dealing with is .dwg, used by some
type of autocad software.  Students are attempting to submit
their assignments to the Prof and the files are unusable.
The only workaround is to zip the file first, and then this
is transmitted OK.

Here is what we've tried:

update to most current packages from Redhat
update Pear modules
disable only fileinfo extension in php.ini
disable only mime_magic.magicfile reference in php.ini
disable both extensions
use only $conf['mime']['magic_db'] = '/usr/share/file/magic.mime'; in conf.php
disable both extensions and the conf.php line

Regardless of what is done, the attachment is always messed up via
the wrong sort of upload.  Does anyone have a method by which
we can get things working with base64 uploads without changes
to the browser end?


More information about the horde mailing list