[horde] Migrating to a new Horde install

lst_hoe02 at kwsoft.de lst_hoe02 at kwsoft.de
Thu Mar 31 09:48:59 UTC 2011

Zitat von Jan Schneider <jan at horde.org>:

> Zitat von lst_hoe02 at kwsoft.de:
>> Done like described aka use a copy of the Horde3 Database and try  
>> to do schema upgrade with Horde4 and IMP/Turba/Kronolith/Nag/Mnemo.  
>> All worked well until nag schema upgrade ended with thrashing the  
>> installation:
> What do you mean with "nag schema upgrade"? The backtrace is coming  
> from loading the sidebar and doesn't have anything to do with  
> upgrading.
> Also, since this is user-specific code, is this happening for every user?

It occured at nag schema upgrade eg. white screen and the mentioned  
error. But as of now it is gone after starting over with a fresh  
database clone and executing the upgrade script for Horde4/PostgreSQL  
(convert TEXT to BYTEA) *before* doing the schema upgrades. So this  
problem is solved, coming to the next:

The Kronolith "convert_to_utc.php" is not working, it fails as follow

require_once(/usr/share/php/data/kronolith/scripts/upgrades/../../lib/Application.php): failed to open stream: No such file or directory in /usr/share/php/data/kronolith/scripts/upgrades/convert_to_utc.php on line  

Fatal error: require_once(): Failed opening required  
(include_path='.:/usr/share/php:/usr/share/pear') in  
/usr/share/php/data/kronolith/scripts/upgrades/convert_to_utc.php on  
line 8

when i copy the "scripts" directory to the webroot directoy of  
kronolith and start it from there i get this one

Fatal error: Call to a member function setObs() on a non-object in  
/usr/share/php/Horde/Perms/Sql.php on line 130

Thanks for any help



-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 6046 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://lists.horde.org/archives/horde/attachments/20110331/0a0d5abe/attachment.bin>

More information about the horde mailing list