[horde] Migrating to a new Horde install

lst_hoe02 at kwsoft.de lst_hoe02 at kwsoft.de
Fri Apr 1 08:25:05 UTC 2011

Zitat von Simon Brereton <simon.brereton at dada.net>:

>> From: horde-bounces at lists.horde.org [mailto:horde-
>> bounces at lists.horde.org] On Behalf Of lst_hoe02 at kwsoft.de
>> Zitat von Jan Schneider <jan at horde.org>:
>> >
>> > Zitat von lst_hoe02 at kwsoft.de:
>> >
>> >> Done like described aka use a copy of the Horde3 Database and try
>> to
>> >> do schema upgrade with Horde4 and IMP/Turba/Kronolith/Nag/Mnemo.
>> >> All worked well until nag schema upgrade ended with thrashing the
>> >> installation:
>> >
>> > What do you mean with "nag schema upgrade"? The backtrace is coming
>> > from loading the sidebar and doesn't have anything to do with
>> > upgrading.
>> > Also, since this is user-specific code, is this happening for every
>> user?
>> It occured at nag schema upgrade eg. white screen and the mentioned
>> error. But as of now it is gone after starting over with a fresh
>> database clone and executing the upgrade script for Horde4/PostgreSQL
>> (convert TEXT to BYTEA) *before* doing the schema upgrades. So this
>> problem is solved, coming to the next:
> Andreas
> Can I just clarify the steps you've taken please?
> Something like:
> pear channel-discover pear.horde.org
> pear install horde/horde_role-beta
> pear run-scripts horde/horde_role
> pear install --alldeps horde/horde-beta
> pear install horde/imp-beta
> pear install horde/kronolith-beta
> pear install --alldeps horde/mnemo-beta
> pear install horde/turba-beta
> pear install horde/ingo-beta
> etc..

Yes to some degree. I have installed the Alpha and done a upgrade to the RC.

> Clone the current horde3 db to horde4
> execute the upgrade script for Horde4/PostgreSQL


> cd /usr/share/horde4/config/
> cp conf.php.dist conf.php

This i have done already before. I have first setup a complete new  
database and configured Horde and the Apps for the first time to test  
if its working. Then i switched over the database to the clone of the  
Horde3 database and do the schema upgrades.

> Go to the Administration Panel
> Update Schemas
> Then configure the components?
> And this successfully copies contact/calendar and sync devices data?

I have not yet finished because the contacts need adjustment as we  
have more than one table, some of them are read only mapped with a  
non-Horde Schema (SAP).
What is partly working is the event data, but the conversation to UTC  
is not working until now.
SyncML seems to be there but i have not connected any device to test.

> So far on the test server I have Horde up and running, but I have no data.

Have you checked the tables if they are empty and created test data to  
see where they end up?

> Jan, et al..
> Will the release come with H3.x->H4 upgrade scripts?

As far as i understand the schema upgrades also try to upgrade the data.



-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 6046 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://lists.horde.org/archives/horde/attachments/20110401/8ad46b1e/attachment-0001.bin>

More information about the horde mailing list