[horde] Installation of Horde 4 via Pear

Patrick Domack patrickdk at patrickdk.com
Thu Apr 7 01:41:50 UTC 2011

I think so, got lost in the thread who was responding to who.

For me it looked like it all installed using pear fine, but the  
webpath was empty, till I fixed up those dependencies.

I was attempting to respond to this:

Ok this actually worked!  But it still doesnt work.  Here's what I did:

1- pear channel-discover pear.horde.org  --> worked

2- pear channel-update pear.horde.org  --> worked

3- pear install horde/horde_role  --> worked

4- pear run-scripts horde/horde_role

the last command output:

Including external post-installation script
"/usr/lib/php/PEAR/Installer/Role/Horde/Role.php" - any errors are in
this script
Inclusion succeeded
running post-install script "Horde_Role_postinstall->init()"
init succeeded
Filesystem location for the base Horde application : /var/www/htdocs/horde4

But I go in /var/www/htdocs/ and cannot see a "horde4" folder.
Therefore I cant point my web browser to it...

Quoting Louis-Philippe Allard <lp.allard.1 at gmail.com>:

> Are you referring to the problem I had to install Horde at first (the
> No releases available for package "pear.horde.org/horde_role" install
> failed error), or the non-click-able apps in Horde (once installed)?
> On Wed, Apr 6, 2011 at 8:09 PM, Patrick Domack  
> <patrickdk at patrickdk.com> wrote:
>> Quoting Vilius ?umskas <vilius at lnk.lt>:
>>>> Does case make a difference, i.e. pear install horde/Horde_Role?
>>> It doesn't.
>> This happened for me also, I found it was cause of missing and outdated
>> dependencies. Once I manually installed them, it worked fine.
>> If I remember correctly, Net_SMTP was the one it got hung up one with my
>> install, also installed Text_CAPTCHA.
>> --
>> Horde mailing list
>> Frequently Asked Questions: http://horde.org/faq/
>> To unsubscribe, mail: horde-unsubscribe at lists.horde.org

More information about the horde mailing list