[horde] Installation of Horde 4 via Pear

Jan Schneider jan at horde.org
Thu Apr 7 08:23:34 UTC 2011

Zitat von Louis-Philippe Allard <lp.allard.1 at gmail.com>:

> On 2011-04-06, at 9:41 PM, Patrick Domack <patrickdk at patrickdk.com> wrote:
>> I think so, got lost in the thread who was responding to who.
>> For me it looked like it all installed using pear fine, but the  
>> webpath was empty, till I fixed up those dependencies.
>> I was attempting to respond to this:
>> Ok this actually worked!  But it still doesnt work.  Here's what I did:
>> 1- pear channel-discover pear.horde.org  --> worked
>> 2- pear channel-update pear.horde.org  --> worked
>> 3- pear install horde/horde_role  --> worked
>> 4- pear run-scripts horde/horde_role
>> the last command output:
>> Including external post-installation script
>> "/usr/lib/php/PEAR/Installer/Role/Horde/Role.php" - any errors are in
>> this script
>> Inclusion succeeded
>> running post-install script "Horde_Role_postinstall->init()"
>> init succeeded
>> Filesystem location for the base Horde application : /var/www/htdocs/horde4
>> But I go in /var/www/htdocs/ and cannot see a "horde4" folder.
>> Therefore I cant point my web browser to it...
> Oh ok!  This is fixed now.  Vilius was right.  Once I ran
> pear run-scripts horde/horde_role
> I had to actually install horde as per the readme file with
> Pear install horde/horde
> And all went fine.  I copied the conf.php.dist to conf.php and  
> pointed my browser to the root where horde is installed.  Then I  
> configured horde but my problem now is that I cant click on the apps  
> name, they seems to be somehow deactivated or misconfigured as they  
> are not links like horde at the top of the list.   I hope my  
> description is easy to understand...

Which applications? And did you actually install any?


Do you need professional PHP or Horde consulting?

More information about the horde mailing list