[horde] Two horde version running on the same system

Gerard Breiner gerard.breiner at ias.u-psud.fr
Mon May 30 09:52:32 UTC 2011

Le 27/05/2011 18:35, Vilius Šumskas a écrit :
> Sveiki,
> Friday, May 27, 2011, 6:03:27 PM, you wrote:
>> Le 27/05/2011 10:33, Vilius S(umskas a écrit :
>>>> 1.0.0, version<= 2.0.0, excluded versions: 2.0.0), installed version is
>>>> 0.0.2
>>>> No valid packages found
>>>> install failed
>>>> Any suggestion are welcome...
>>> You have old CVS version packages installed, and PEAR installer picks up wrong dependencies. In this case you'll need to install Horde4 into separate PEAR folder. You can find more information installation documentation:
>>> http://www.horde.org/apps/horde/docs/INSTALL#installing-with-pear
>> Many thanks Vilius...
>> Could tell me please if there is a mean to uninstall these old packages
>> ? My server in production is horde-webmail-1.2.8 (not CVS) but before
>> this stable version I had unsuccessfull tried  to setup Horde-git a few
>> month ago.
> Then  just uninstall horde-git packages from PEAR and install released
> ones. Something like:
> pear list -c horde
> pear uninstall horde/Horde_Core
> pear uninstall horde/Horde_Auth
> etc.
>> Nevertheless, as I had the reported error above, I had eventually decide
>> to install horde4 into a different pear folder.
>> Here is the chronological order  of the install method I followed :
>> In root :
>> cd /www
>> mkdir horde4
>> pear config-create horde4 horde4/pear.conf
>> pear -c  horde4/pear.conf install pear
>> As I got the warning message :  "WARNING: channel "*pear*.php.net" has
>> updated its protocols, use "*pear* channel-update *pear*.php.net" to
>> update" I run :
>> *pear* channel-update *pear*.php.net
>> horde4/pear -c horde4/pear.conf channel-discover pear.horde.org
>> horde4/pear -c horde4/pear.conf install horde/horde_role
>> horde4/pear -c horde4/pear.conf  run-scripts horde/horde_role
>> At the prompt : Filesystem location for the base *Horde* application :
>> /www/horde4
>> horde4/pear -c horde4/pear.conf install horde/horde
>> Then into the .htaccess file I put :
>> php_value include_path /www/horde4/*pear*/php
>> SetEnv PHP_PEAR_SYSCONF_DIR /www/horde4
>> chown -R horde4 user:group(apache) horde4
>> /etc/init.d/apache stop
>> /etc/init.d/apache start
>> In firefox : http://mywebmail .... At that time it worked very
>> fine... I mean at that time I had an admin interface
>> but afterward the horde's conf.php file has been generated I
>> obtained an error message when I reload http://mywebmail
> What error?
>> ... At that time I thought it was worth to uninstall and install again horde...
>> So I ran : horde4/pear -c horde4/pear.conf uninstall horde/horde
>> An then :
>> horde4/pear -c horde4/pear.conf install -a horde/horde
>> The interface appears again but without the treemenu admin/setup
>> So I after having checked the apache error log : tail
>> /var/log/apache2/horde-test_error_log
>> I get : File does not exist: /www/horde4/js/hordetree.js, referer:
>> https://webmail1.ias.u-psud.fr/services/portal/
>> So I ran : ./pear/pear -c pear.conf list-files horde/horde_core | more
>> ====================================
>> horde /www/horde4/js/addressbooksprefs.js
>> horde /www/horde4/js/alarmprefs.js
>> horde /www/horde4/js/autocomplete.js
>> horde /www/horde4/js/calendar.js
>> horde /www/horde4/js/hordetree.js
>> It seems that according pear hordetree.js exist but in reality it is missed...
>> Any suggestion are welcome...
> By  uninstalling  horde/horde  you  have  removed a whole /www/horde4/js
> folder. But files from other packages are installed there too. Just uninstall and reinstall Horde_Core.

Many thanks again Vilius for your gentle help... Satursday I took a few 
minutes to uninstall and install horde by following your advices... At 
this time all works very fine... I mean the admin/setup interface works. 
It remains to me to setup Horde's parameters...

Best regards


More information about the horde mailing list