[horde] (SOLVED) grandchild failed in cron

Andreas Mauser andreas at mauser.info
Wed Apr 25 15:04:04 UTC 2012


----- Nachricht von Andreas Mauser <andreas at mauser.info> ---------
   Datum: Tue, 17 Apr 2012 23:24:31 +0200
     Von: Andreas Mauser <andreas at mauser.info>
Betreff: Re: [horde] grandchild failed in cron
      An: horde at lists.horde.org

> Hi,
> ----- Nachricht von Vilius Šumskas <vilius at lnk.lt> ---------
>   Datum: Tue, 17 Apr 2012 23:49:06 +0300
>     Von: Vilius Šumskas <vilius at lnk.lt>
> Betreff: Re: [horde] grandchild failed in cron
>      An: horde at lists.horde.org
>> Hi,
>> Andreas Mauser <andreas at mauser.info> rašė:
>>> Ok, after some testing I disabled any memcaching in Horde, and I  
>>> uninstalled memcached.
>>> As Cache System I choose 'Store data in filesystem'.
>>> I deleted all files out of the cache directory  
>>> /var/www/horde-cache which I set in Horde, then I rebootet the  
>>> server, to make sure it all works.
>>> After a reboot I logged into Horde and was able to clear the cache  
>>> on the console.
>>> After a while, lets say 5-10 minutes I run this command:
>>> root at webster:~ # php -d  
>>> include_path=/var/www/mauser.info/mailoffice/pear/php  
>>> /var/www/mauser.info/mailoffice/pear/horde-clear-cache
>>> PHP Fatal error:  Call to a member function setObs() on a  
>>> non-object in  
>>> /var/www/mauser.info/mailoffice/pear/php/Horde/Perms/Sql.php on  
>>> line 130
>>> root at webster:~ # rm -rf /var/www/horde-cache/*
>>> root at webster:~ # php -d  
>>> include_path=/var/www/mauser.info/mailoffice/pear/php  
>>> /var/www/mauser.info/mailoffice/pear/horde-clear-cache
>>> Are you sure you want to expire all cached data?
>>>   (y) Yes
>>>   (n) No
>>> Ihre Auswahl [n]: y
>>> [   OK   ] Cache data cleared.
>>> root at webster:~ # /usr/bin/php -d  
>>> include_path=/var/www/mauser.info/mailoffice/pear/php/  
>>> /var/www/mauser.info/mailoffice/pear/horde-alarms
>>> root at webster:~ #
>>> So if I use memcache or local files, after a while I get the  
>>> grandchild error.
>>> As it works for a while I assume the problem must be somewhere in  
>>> (my) Horde.
>>> Can someone please look into that again?
>> This just confirms what Jan said earlier. Your cache becomes  
>> corrupted for some strange reason.
>> My last shot to the sky would be: do you happen to run multiple  
>> copies of Horde using the same cache folder? If not then you need  
>> to debug this on your own PHP line by line. As I cannot reproduce  
>> it on my systems (my Horde cache is using /tmp folder).
> But what is the mechanism behind these file based cache?
> And how can the cache become corrupted?
> Maybe you can tell some of the most usual reasons for that, so I can  
> have a closer look?
> My cache folder is
> drwxr-xr-x  2 www-data www-data  12K 17. Apr 23:21 horde-cache
> Maybe you have some more hints.
> During the following days I will set up a CentOS6 box, do a plain  
> installation of LAMP and Horde and move in the DB and the files from  
> /var/www/horde-tmp which I use for Ansel as suggested. I'll let you  
> know the result.

It must be Debian related.

I removed the Horde specific entries in crontab and moved them to a  
script.sh in /usr/local/bin.
This script.sh I put in crontab instead of the original entries.

This makes the grandchild error go away, and - please correct me - it  
is doing the very same function.

Thank you for all the helpful information!
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 4975 bytes
Desc: S/MIME Signatur
URL: <http://lists.horde.org/archives/horde/attachments/20120425/b6f52b5b/attachment-0001.bin>

More information about the horde mailing list